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PREFACE

elcome to GeoSource, the electrical source-imaging 
software from Electrical Geodesics, Inc. (EGI). As a 

complement to EGI’s Net Station electroencephalography 
(EEG) acquisition, review, and analysis application, 
GeoSource uses inverse techniques to approximate the 
source data for any Net Station EEG file that does not 
contain bipolar channels. 

The source data files generated by GeoSource are 
compatible with many of Net Station’s Waveform Tools, 
which allows you to perform the same operations on the 
GeoSource source data files as you would on Net Station EEG files.

Main Features

GeoSource allows you to:

• display source data in Chart, Grid, or Synoptic Plot views in the Net Station
Viewer or on magnetic resonance image (MRI) slices in the GeoSource Viewer

• create source montages for viewing subsets of source data in Net Station Viewer
• create a GeoSource specification in the Waveform Tools
• export source data in a variety of formats: modified Net Station, modified simple

binary, MATLAB .MAT, or tab-delimited text

This manual, the GeoSource Technical Manual, is intended for researchers and 
clinicians who are involved in the acquisition, processing, analysis, and modeling of 
EEG data.

W
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The GeoSource Technical Manual assumes you have some familiarity with basic 
concepts in neuroscience, physics, and linear algebra.

Other Net Station manuals include:

• Net Station Viewer Technical Manual. This
manual describes the features and functions of the
Net Station Viewer, which is the component of Net
Station that views and navigates EEG data.

• Net Station Waveform Tools Technical Manual.
This manual describes the features and functions
of the Net Station Waveform Tools, which are the
components of Net Station that perform various
operations on EEG data (primarily for basic ERP
derivation).

• Net Station Viewer and Waveform Tools Tutorial. This manual instructs you in
the use of the Net Station Viewer and the Waveform Tools by guiding you
through the analysis of a sample data set. It is not intended to be a
comprehensive guide to these components, but it is a good place to start when
learning about the software.

• Net Station Acquisition Technical Manual. This manual describes features and
functions of the Net Station Acquisition, which is the component of Net Station
that acquires EEG in conjunction with the dense-array Geodesic Sensor Nets.

• Net Station File Formats Technical Manual. This manual documents the objects
contained in a native Net Station file, the formats of the export files, and other
files associated with Net Station.

Note: You can find the PDF versions of these publications and other EGI documentation at 
www.egi.com/membership-area.

These publications contain a good deal of background information on the EEG and 
ERP fields. However, they are not intended to represent a complete primer in these 
fields. To get the most out of these manuals, you should have some experience with 
EEG and ERP methods. 

These manuals assume you are familiar with the hardware and software components 
of the Macintosh platform, which is the platform that Net Station runs on. 

Net Station logo
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About This Manual

This manual is supplied as a PDF file and in printed form. The hard copy version has 
been printed from the PDF file so the content of both will match. 

The manual features a table of contents, list of figures, list of tables, and index, which 
are all hyperlinked in the PDF to the topics they reference in the publication. 

Manual Organization
The manual is divided into the following chapters: 

• Chapter 1, "Introduction to GeoSource”
• Chapter 2, "GeoSource Menus and Windows”
• Chapter 3, "Getting Started”
• Chapter 4, "Source-Imaging Specifications”
• Chapter 5, "GeoSource File Organization”
• Appendix A, "Software Technical Support”
• Glossary

Conventions and Typography
In general, a minimal amount of special fonts are used in this manual—italics for 
definitions or newly introduced terms, boldface italics for especially important 
concepts, and boldface for command paths (such as File > Open).

Notes, Cautions, and Warnings
Notes, cautions, and warnings are used to convey additional information regarding 
this product.

Note: Notes indicate information that may be helpful in understanding product operation.

CAUTION: Cautions denote important information that, if unheeded, could result in 
injury or equipment damage or hinder the use of the product.

WARNING: Warnings denote important information that, if unheeded, could result 
in serious injury or death. 
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Support, Repair, and Documentation
• For GeoSource support, see

Appendix A.

• For online updates to this book,
check EGI’s documentation
pages at www.egi.com/
membership-area.

Documentation webpages



Chapter 1

17GeoSource 2.0 Technical Manual  8103101-52 • March 9, 2015

CHAPTER 1INTRODUCTION 
TO GEOSOURCE

he purpose of EGI’s GeoSource software is to take the dense array (128 or 256 
channel) electroencephalography (EEG) data measured on the scalp with the 

Geodesic Sensor Net (GSN) and recorded in a Net Station EEG file, and to use inverse 
techniques to estimate the source locations in the brain. The source data files that 
result from GeoSource’s source estimation calculations are compatible with the 
following Waveform Tools:

• averaging
• baseline correction
• combine files
• difference wave
• file export
• filtering
• statistic extraction
• t-test
• wavelet

GeoSource should be used by trained personnel for EEG source calculation, review, 
and analysis. GeoSource does not perform a diagnostic function. It provides another 
data point that may help make inferences about brain function.

WARNING: Source estimation refers to methods that are employed for estimating the 
current sources of scalp recorded EEG. There are two classes of methods: linear and 
nonlinear. Each class employs different approaches to source estimation, which is an ill-
posed problem. In the nonlinear class are methods that employ equivalent dipoles, and 
in the linear class are methods that employ different constraints applied to a minimum 
norm solution. Because source estimation is an ill-posed problem, there are no unique 
answers. Therefore, estimates of current sources from scalp recorded EEG data, 
whether they are derived from linear or nonlinear techniques, are approximate, and 
should always be viewed in the context of the scalp data by a trained reviewer.

This chapter describes the software’s official intended use and system requirements, 
and then introduces you to the general concepts involved in GeoSource.

T
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Intended Use

GeoSource is intended for use by a trained/qualified EEG technologist or physician on 
both adult and pediatric subjects of at least three years of age for the visualization of 
human brain function by fusing a variety of EEG information with rendered images of 
an idealized head model and an idealized MRI image.

WARNING: GeoSource has only been validated with 128- and 256-channel data. 
GeoSource should only be used if greater than or equal to 128 channels of EEG 
are used.

System Requirements

GeoSource is available only in Net Station 4.3 or 
later, and is designed to run on Mac OS X 10.6. 
It has been specified to run on a PowerMac G5 
or Mac Pro (Figure 1-1) that has at least a 2 GHz 
processor and at least 2 GB or more of random-
access memory.

Generic Forward and Inverse Problems

Source imaging involves solving a forward problem and an inverse problem. 

In simple terms, the generic forward problem is: 

Given known source locations and propagation model, what are the surface 
measurements? 

The solution is then “flipped over” to solve the generic inverse problem, which is: 

Figure 1-1. PowerMac G5
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Given known surface measurements and propagation model, what are the source 
data? See Figure 1-2.

EEG Forward and Inverse Problems

In GeoSource, you create specifications that combine the different components for 
solving the forward and the inverse problems as applied to source imaging. Those 
components are: 

• EEG sources. Locations of possible generators.

• Forward head models. Models that describe the propagation of current through
a conductive medium (i.e., the head).

• Inverse models. Models that produce a unique answer from the infinite number
of possible answers to the inverse problem.

In GeoSource, source estimation is obtained by combining:

• a source-imaging specification, which contains forward and inverse models; and
• EEG scalp data from a Net Station file.

Source specifications can be used in the Net Station Viewer or with the Waveform 
Tools. For the former, you can apply a source-imaging specification to describe the 
source estimates during data review. For the latter, you can define a GeoSource 
specification (which contains a source-imaging specification and output options) and 
use the resulting tool for batch processing or scripting to generate source files.

The individual components of the forward and inverse models in GeoSource are 
described in Chapter 2, "GeoSource Menus and Windows.”

Figure 1-2. Generic forward and inverse problems

?

Forward problem

?
Inverse problem
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A Recommendation

GeoSource contains a selection of default source-imaging specifications based on the 
well-known LAURA, LORETA, and sLORETA source-imaging methods. GeoSource 
also allows you to create your own source-imaging specifications.

The solutions provided by GeoSource are approximations of the locations of sources 
that are responsible for generating the EEG that is recorded at the scalp. It is a good 
idea to apply different source-imaging specifications to the same data for comparison, 
and to use GeoSource in conjunction with other EEG analysis techniques to determine 
if the solutions are consistent with the recorded data.

Regulatory Compliance

European Union (EU) Authorized Representative

Symbols
Mark indicating that the product is CE compliant. The number 0297 is 
the EC reference number of the VDE Testing and Certification 
Institute, the notified body for Electrical Geodesics, Inc.

Contact: Gerhard Frömel 

Mailing
Address:

MPS
Medical Product Service GmbH
Borngasse 20
35619 Braunfels
Germany

Telephone:

Fax:

Email:

011 49 6442 962073
011 49 6442 962074 
g.froemel@mps-gmbh.edu
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CHAPTER 2GEOSOURCE MENUS 
AND WINDOWS

his chapter describes GeoSource’s menus and windows, which are accessible from 
either the Net Station Viewer (page 21) or the GeoSource Viewer (page 39). 

Net Station Viewer

The Net Station Viewer displays source and EEG data nearly identically. The 
exceptions are that the source data can be displayed only in chart, grid, or synoptic 
plot views (see page 31), and the tiles to the left indicate the dipole numbers (not the 
channel numbers). For example, Figure 2-1 shows source data as continuous data in a 
chart view in the Net Station Viewer. 

Figure 2-1. Net Station Viewer showing source data as continuous data in a chart view

T

Dipole 
numbers
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The Net Station menu bar is visible when a Net Station Viewer is frontmost on the 
monitor screen.

The following section describes the GeoSource-specific features and functions in 
detail. For descriptions of common Net Station Viewer features, see the Net Station 
Viewer Technical Manual.

Net Station Viewer Menus

Which menus and options are available onscreen from the Net Station Viewer menu 
bar (Figure 2-2) is determined by the space (source or scalp), view (chart, grid, etc.), 
category-viewing mode (as continuous data, etc.), and source-viewing mode 
(waveforms or MRI) of the currently open file or view (if not yet saved as a file). For 
details, see “What to Know Before Getting Started” on page 54.

When viewing source data, the following Net Station Viewer menus enable 
GeoSource-specific functions.

• File. Saves source data in a variety of formats.

• Edit. Selects source data.

• Docs. Maintains a list of all open files and minimizes selected files to the Dock.

• Tools. Creates a GeoSource specification.

• Workspace. Saves different combinations of view settings to open files with.

• View. Displays source data as continuous data, categories, or overlaid segments
in chart, grid, or synoptic plot views. If the open file is in source space, the View
menu can display source data as overlaid source components or the RMS of
source components in a chart view.

• Time. Changes the time scale of the source data.

• Amplitude. Changes the amplitude of the source data.

• Montage. Applies a source montage to the source data.

Figure 2-2. Net Station Viewer menu bar
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• Events. Manages events in the source data.

• Filter. Unavailable.

• GeoSource. Opens the GeoSource Controls window (Figure 2-15) or the Source-
Imaging Specification Editor window (Figure 2-16). The GeoSource Controls
window allows you to apply GeoSource specifications and view the source data
as waveforms or in the GeoSource Viewer. The Source-Imaging Specification
Editor windows allows you to create or edit source-imaging specifications.

File > Save
The File menu allows you to save a source data file or source data selection in a variety 
of formats.

• To save a source data file, choose File > Save A Copy As.

• To save a source data selection, highlight a selection of a file in the Net Station
Viewer and choose File > Save Selection (Figure 2-3).

Choosing either command opens the File Save As or the Save Selection As dialog, 
which allows you to save your source data in a variety of file formats. See Figure 2-4.

Figure 2-3. File menu
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Note: If you are seeing a longer list of available formats than are shown in Figure 2-4, you have 
not yet converted the original Net Station EEG recording file into a GeoSource view (or file). 
Stop, and review the “What to Know Before Getting Started” section in Chapter 3. You must 
create a GeoSource view using a source-imaging specification before you can convert an 
original Net Station EEG recording file into a GeoSource file.

The following are brief descriptions of the items in Figure 2-4.

Save As. Allows you to type in a name for the output file.

Where. Allows you to select a destination for the output file. (Figure 2-4 shows 
the Where item expanded with the adjacent arrow.)

Format. Allows you to select a format for the output file. Options are:

Net Station MFF Recording. This format stores sample data in binary blocks 
and stores information about those samples in XML text files. For more 
information, request MFF documentation from EGI Support at 
supportteam@egi.com.

Source Binary File. This format is similar to a normal simple-binary file. For 
more information, see page 104.

Figure 2-4. Save Selection As dialog
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Tab-delimited Text. This format represents each block of EEG data as text. It 
creates one text file per segment of EEG. For more information, see page 105.

MATLAB (.mat). This format is used in MATLAB programs. For more 
information, see page 105.

Net Station Recording. This format is similar to a Net Station EEG recording 
file. For more information, see page 104.

Export Options. Allows you to specify the format of the exported data:

Output Precision. Only applicable for two formats: the Net Station Recording 
format and the Net Station MFF Recording format. Allows you to choose the 
data-type precision of the output file. Options are:

– Floating Point. This option produces more precise files, but the files
export more slowly and they are larger than with the Integer option.

– Integer. This option creates smaller files (about half the size) that export
faster, but the files produced are less precise than with the Floating Point 
option.

Convert to Microvolts. Never selectable; dimmed for all five output options, 
because it is not applicable. The units for the source waveforms are nanoamp 
meters.

Apply Viewer Transformations. Never selectable; defaults as appropriate. 
If this checkbox is selected (i.e., checked), the data are saved as source data. 
If unselected (i.e., unchecked), the data are saved as EEG scalp data.

New Folder. Allows you to create a new folder in which to place the file.

Cancel and Save As. Whereas Save As saves a file while closing the dialog, 
Cancel closes the dialog without saving a file.

Tools > Waveform Tools
The GeoSource Specification Editor window (Figure 2-6) allows you to create a 
source-imaging tool that can be added to a script or used to process a batch of files. 
Different from a source-imaging specification (see Chapter 4, “Source-Imaging 
Specifications”), a GeoSource specification tool consists of EEG sources, source-
imaging specification, and output format (Net Station recording or source binary). 
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To create a GeoSource specification tool, open the GeoSource Specification Editor 
window by choosing Tools > Waveform Tools and selecting GeoSource from the 
Create pop-up menu of the Waveform Tools window (Figure 2-5).

Figure 2-5. Waveform Tools window



Chapter 2: GeoSource Menus and Windows

27GeoSource 2.0 Technical Manual  8103101-52 • March 9, 2015

Figure 2-6 shows the GeoSource Specification Editor window.

The following are brief descriptions of the items in Figure 2-6.

GeoSource Specification Name. Allows you to enter a name to identify a new 
GeoSource specification tool.

Output Options. Allows you to add an extension to the files created by the new 
specification tool and to direct those files to a specific directory.

Name. Allows you to select an extension (or a prompt for customizing the 
extension) for all files processed by the new specification tool.

Destination. Specifies the destination for all files created by the new 
specification tool.

Update file to MFF. Writes the output as an MFF file.

Source-Imaging Specification (list and editing buttons). Allows you to select the 
source-imaging specification to use in solving the inverse problem. Click to the 
left of the desired specification name. A green dot will appear next to the 
selection. For more information about source-imaging specifications, see page 97.

Figure 2-6. GeoSource Specification Editor window
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The editing buttons allow you to apply the following functions to a selected 
default or user-defined specification.

New. Opens a blank Source-Imaging Specification Editor window (Figure 2-
16) for creating a new user-defined specification.

Edit. Opens a filled-in Source-Imaging Specification Editor window 
(Figure 2-16) that contains the editable parameters of the user-defined 
specification that was selected in the Source Image Specification list. 

Clone. Opens a filled-in Source-Imaging Specification Editor window 
(Figure 2-16) that contains the editable parameters of the default or user-
defined specification that was selected in the Source Image Specification list. 
The Clone feature appends the word “copy” to the original name to ensure 
that the cloned specification is saved with a different name.

Delete. Opens a dialog confirming that you wish to delete the user-defined 
specification selected in the Source Image Specification list. 

Dipole Set. Allows you to select a dipole set for the named GeoSource 
specification tool. Click in the column left of the desired option. A green dot 
will appear next to the selection.

Note: You must select one item in the list, even if it is the only item listed.

2 mm Atlas Man. This set contains 2,447 dipoles distributed across general 
regions of the cortex. Each dipole is represented as a triple regional source 
made up of three dipoles in the X, Y, and Z orientations. 

This set represents the Montreal Neurological Institute’s (MNI) average MRI 
specification of brain tissue, which is derived from the average of 305 subjects. 
This average MRI specification is well represented in scientific literature for 
use with functional brain imaging data, such as fMRI, and was created to be 
representative of a generalized population (239 M, 66 F, age 23.4 +/- 4.1). 
Information about the average MRI and its use in the scientific literature can 
be viewed at: http://imaging.mrc-cbu.cam.ac.uk/imaging/MniTalairach. 

Source Montages. Allows you to select a source montage for the named 
GeoSource specification tool. Click in the column left of the desired option. A 
green dot will appear next to the selection.

Note: When the 2 mm Atlas Man set is selected and you choose to output the data as a 
Net Station EEG recording file or a Net Station MFF recording file, then you must select 
a source montage from the Source Montages list.
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Data output options. Allows you to specify the file type and source-waveform 
configuration of the output file.

File Type. Sets the file as one of two types. Options are:

– Net Station Recording. This is similar to a Net Station EEG recording file. 
For more information, see page 104.

– Source Binary File. This is similar to a normal simple-binary file. For
more information, see page 104.

Save Data as. Selecting either the Net Station Recording or the Source Binary 
File file type activates the Save Data as buttons, which allow you to save the 
data as one waveform collapsed per dipole location or as three waveforms 
overlaid per dipole location. For details and figures, see the as RMS of Source 
Components and as Overlaid Source Components viewing options on 
page 31.

Tools > Browse Subjects
The Browse Subjects window allows you to enter subject-specific information for a 
Net Station EEG file. To open the Browse Subjects window, choose Tools > Browse 
Subjects (Figure 2-7) from within the file.

The Browse Subjects window contains General, Sessions, Head Models, and MRI 
panes (Figure 2-8). Choosing one of the icons in the Subject Information pane displays 
that icon’s corresponding fields in the lower, right pane. 

Figure 2-7. Browse Subjects menu command
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If the information is not already available, the General pane enables you to enter data 
about the subject’s age, date of birth, experiment ID, experiment name, subject’s 
handedness, etc. Likewise, if session information is not already available, the Sessions 
pane enables you to select a particular session from a list of available session files. 

The following sections describe the Head Models and MRI panes, which are designed 
to automatically use built-in default models for GeoSource operations. 

Head Models Pane
For clinical applications, the Head Models pane automatically uses built-in default 
models provided by Net Station for the subject’s head model.

If Geodesic Photogrammetry System (GPS) coordinates are available for the subject, 
the GPS information is loaded into Net Station and the Head Models pane will list 
information about the GPS file, including the Geodesic Sensor Net model used and the 
date and time of the sensor registration. If multiple GPS sensor-registration files are 
available, Net Station uses the GPS file with the timestamp closest to that of the 
currently open Net Station EEG file.

If the subject has no GPS coordinates, Net Station uses a built-in default 3D coordinate 
set for the sensor layout specified in the Net Station EEG file.

Figure 2-8. Browse Subjects window
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MRI Panes
The MRI panes contain two built-in MRI files:

• MNI typical.hdr. This is a typical MRI file from the Montreal Neurological
Institute (hence, the MNI in the filename). This file is based on one subject’s
brain and represents that subject’s specific anatomy, which closely matches the
average MRI. This file is used to display the actual solutions, which are based
on the average MRI file.

• MNI average.hdr. This is an average MRI file from the Montreal Neurological
Institute. This file is based on the brains of approximately 300 subjects and
represents the average of their collective anatomies. This file is the basis for the
actual solutions that are displayed using the typical MRI file.

Both MRI files are approximations.

View Menu
The View menu allows you to change the appearance of the data in Net Station 
Viewer. You can view source data as continuous data, categories, or overlaid segments 
in a chart, grid, or synoptic plot views (see Figure 2-9). For details about these 
features, see the Net Station Viewer Technical Manual.

In order for the RMS (root-mean-square; see Figure 2-10) and overlaid source 
components (see Figure 2-11) options to be available, your file must be in source space 
(i.e., source waveforms). 

Figure 2-9. View menu

Only chart, grid, and 
synoptic plot views are 
available for source 
data
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The following are brief descriptions of the items in Figure 2-9.

as RMS of Source Components. Displays the source waveforms as collapsed into 
a single waveform (Figure 2-10).

as Overlaid Source Components. Displays each dipole’s three waveforms 
overlaid and color coded (the X component is red, the Y is green, and the Z is 
blue). See Figure 2-11. 

Amplitude Menu
The Amplitude menu allows you to change the amplitude of the waveforms in the 
Net Station Viewer so that you can adjust the visibility of the waveforms. For example, 
if source waveforms appear flat, choosing a very small amplitude value from the 
Amplitude menu may reveal the true shape of the waveforms.

The Amplitude menu for source data is identical to that for scalp data, except it 
contains nanoamp meters rather than microvolts (Figure 2-12).

Figure 2-10. As RMS of Source Components

Figure 2-11. As Overlaid Source Components

red = X component
green = Y component
blue = Z component
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Montage Menu
The Montage menu allows you to display a subset of dipoles that are of specific interest.

You can apply a montage to the source data in the Net Station Viewer one of two ways:

• From the menu bar, choose Montage > {source montage name}.

• From the data-display control strip, choose a source montage from the Montage
pop-up menu (Figure 2-13).

Source montages are created in the GeoSource Viewer. For details, see page 49.

Figure 2-12. Amplitude menu

Figure 2-13. Montage menu (top) and Montage pop-up menu (bottom)

[Menu shorted.]
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GeoSource > GeoSource Controls
The GeoSource menu provides access to the GeoSource Controls window (Figure 2-15) 
and the Source-Imaging Specification Editor window (Figure 2-16), which are two of 
the software’s main windows. See Figure 2-14 for the items of the GeoSource menu.

The GeoSource Controls window allows you to select a source-imaging specification 
at run (i.e., recording) time and to view it in the Net Station Viewer or the GeoSource 
Viewer. To open the GeoSource Controls window, choose GeoSource > GeoSource 
Controls. 

Each GeoSource Controls window is unique to its corresponding Net Station EEG file. 
If you wish to view the source data of another Net Station EEG file, you must open a 
separate GeoSource Controls window from within that file. The name of the 
corresponding Net Station EEG file is displayed at the top of each GeoSource Controls 
window (see Figure 2-15).

Figure 2-14. GeoSource menu

Figure 2-15. GeoSource Controls window
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The following are brief descriptions of the items in Figure 2-15.

Source-Imaging Specifications (list and editing buttons). Displays the available 
source-imaging specifications. Click a specification to select it. The editing 
buttons allow you to apply the following functions to a selected specification:

New. Opens a blank Source-Imaging Specification Editor window 
(Figure 2-16) for creating a new user-defined specification.

Edit. Opens a filled-in Source-Imaging Specification Editor window 
(Figure 2-16) that contains the editable parameters of the user-defined 
specification that was selected in the Source-Imaging Specification list. 

Clone. Opens a filled-in Source-Imaging Specification Editor window 
(Figure 2-16) that contains the editable parameters of the default or user-
defined specification that was selected in the Source-Imaging Specification list. 
The Clone feature appends the word “copy” to the original name to ensure 
that the cloned specification is saved with a different name.

Delete. Opens a dialog confirming that you wish to delete the user-defined 
specification selected in the Source-Imaging Specification list. 

View as Waveforms and View in MRI (for the source-viewing modes). Displays 
the source data either in the Net Station Viewer as waveforms (see page 21 and 
page 59) or in the GeoSource Viewer as dipole intensities overlaid on an MRI 
(see page 39 and page 60). The name of the source data file is automatically 
displayed in the View list.

View list. Lists the currently open source data windows. This list can be sorted by 
column (window type, Matrix Name, Data From, or linked/unlinked) in either 
ascending or descending alphabetical or iconic order. Double-clicking in a 
specific row brings the selected window to the front.

Ascending/descending order. To the far right of the view list is the ascending/
descending order toggle button, which shows the ascending ( ) icon for 
ascending ordering and the descending ( ) icon for descending ordering. 
Click it to change the direction of the ordering.

Window-type column. The window-type column has a blank header row icon 
( ) and has two icons in the rows below that indicate window type: 
waveform windows ( ) and MRI windows ( ). 

Data From column. The Data From column, which is applicable to source data 
displayed in both the GeoSource Viewer and the Net Station Viewer, identifies 
the EEG window supplying the data. If the data in the EEG windows are 
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displayed as continuous data or as categories, you can cycle through the 
available windows by clicking a file name in the Data From column. 

For example, whereas the same scalp data may be displayed in multiple 
windows, a 60-Hz notch filter may be applied in Window 1 and a 40-Hz 
highpass filter may be applied in Window 2. As a result, three EEG windows 
will be available in the Data From column:

• a recording file, which provides unprocessed data to the GeoSource
Viewer for display on the 3D MRI slices;

• Window 1, which provides 60-Hz filtered data; and
• Window 2, which provides 40-Hz filtered data.

Close Window. Closes any source data window selected in the View list.

GeoSource > New Source-Imaging Specification

Choose GeoSource > New Source-Imaging Specification to open the Source-Imaging 
Specification Editor window (Figure 2-16), which allows you to create or edit a source-
imaging specification. A source-imaging specification consists of the forward head 
model, inverse method, and various mathematical techniques.

The following are brief descriptions of the items in Figure 2-16.

Forward Head Model. Two models are available: 

Sun-Stok 4-Shell Sphere. This is a spherical model that consists of four shells 
representing the cortex, cerebrospinal fluid, skull, and scalp.

Figure 2-16. Source-Imaging Specification Editor window



Chapter 2: GeoSource Menus and Windows

37GeoSource 2.0 Technical Manual  8103101-52 • March 9, 2015

Finite Difference Model. This is a head model that captures the typical 
geometry of the human head tissues, including the cortex, cerebrospinal fluid 
(CSF), skull, and scalp. 

For more information about the forward head models, see Chapter 4, 
“Forward Algorithms for EEG” on page 97.

Constraint (of the Inverse Model). The following schemes are available to 
constrain the source space before the source-imaging specification is applied 
to the Net Station EEG file. Options are:

None. Applies no constraint scheme.

LORETA (low-resolution brain electromagnetic tomography). This scheme 
selects the solution with the smoothest spatial distribution.

LAURA (local autoregressive average). This scheme is based on the 26 closest 
neighbors for each location.

sLORETA (standardized low-resolution brain electromagnetic tomography). This 
scheme standardizes the source current density such that there is equal 
sensitivity for deep and superficial sources.

If you choose the LAURA constraint, then additional parameters (Radius of 
Influence and Exponent) appear that pertain only to the LAURA solution. See 
Figure 2-17. You can use the default values for those parameters or refer to 
Grave de Peralta and Gonzalez Andino (2002) for more information. 

For more information about the constraint schemes, see Chapter 4, 
“Constraint Schemes” on page 100.

Regularization (of the Inverse Model). A method that adds information to 
stabilize an ill-posed problem. Options are:

None. Applies no regularization method.

Figure 2-17. LAURA parameters

Tikhonov regularization No regularization
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Tikhonov. Adds a small regularization parameter to all singular values, thus 
disproportionally increasing the small values. 

For more information about regularization, see Chapter 4, “Regularization” 
on page 102.

Don’t Save and Save. Whereas Save saves all changes while closing the window, 
Don’t Save closes the window without saving changes. New specifications 
that are saved automatically appear in the GeoSource Controls window 
(Figure 2-15) and the GeoSource Specification Editor window (Figure 2-6) that 
is opened from the Waveform Tools window.

Default Source-Imaging Specifications
While you can define your own user-defined source-imaging specifications, 
GeoSource also provides three default source-imaging specifications for displaying 
source data. When you apply a default source-imaging specification to your scalp 
data, the following values are used to display the corresponding source data. 

These values are available from the GeoSource Controls window and are based on 
values published in peer-reviewed scientific literature. 

Default LAURA Source-Imaging Specification

• Forward head model: Sun-Stok 4-shell sphere
• Inverse model:

– Regularization: Tikhonov (1 x 10 and -4)
– Constraint: LAURA

–Radius of Influence: 12.2000 mm
–Exponent: 3

Default LORETA Specification

• Forward head model: Sun-Stok 4-shell sphere
• Inverse model:

– Regularization: Tikhonov (1 x 10 and -3)
– Constraint: LORETA
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Default sLORETA Specification

• Forward head model: Sun-Stok 4-shell sphere
• Inverse model:

– Regularization: Tikhonov (1 x 10 and -2)
– Constraint: sLORETA

GeoSource Viewer

The GeoSource Viewer (Figure 2-18) displays source data as dipoles overlaid on 3D MRI 
slices. Separate from the Net Station Viewer, the GeoSource Viewer can be accessed only 
by clicking the View in MRI button in the GeoSource Controls window (see page 34).

The following are brief descriptions of the items in Figure 2-18.

Crosshairs. When selected (darkened), this button displays the crosshairs 
overlaid on all three MRI panes. Clicking in an MRI pane selects that pane as 
the focus pane, which is indicated by a yellow crosshairs. As you navigate 

Figure 2-18. GeoSource Viewer
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through the focus pane, the other two panes will update accordingly. This 
button is selected by default. Click it to deselect it.

Flat Map. This button opens the Flat Map window (see page 46). 

Jump to Max. When selected (darkened), this button ensures that each MRI pane 
is automatically centered on the dipole with the highest intensity value when 
it receives new time points as the EEG data are played in the Net Station 
Viewer. This button is selected by default. Click it to deselect it. 

Sliders for brightness and contrast. Adjusts the brightness and contrast in all 
three MRI panes.

Brightness (left slider). The left slider adds or subtracts values from each pixel 
to lighten or darken the images uniformly.

Contrast (right slider). The right slider changes the rate of change from black 
to white, or from white to black, in the images to emphasize or de-emphasize 
the differences in shading.

File information. Displays information about the data file.

Filename indicator. Displays the filename for the scalp data. 
Source specification indicator. Displays the source-imaging specification used.
Time indicator. Displays the time under the Time Synch marker in the 
Net Station Viewer. 
Data From indicator. Lists the EEG window providing the data to the 
GeoSource Viewer. 

Palette. When selected (darkened), this button opens the palette drawer. See the 
next section, which is titled “Palette Drawer”.
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MRI panes. Displays dipole intensities overlaid onto the sagittal, coronal, and 
axial MRI slices (see Figure 2-18). The dipoles are approximately represented 
by voxels, which are colored 3D volume pixels. 

MRI slice sliders, text boxes, and arrow buttons. If an MRI pane is selected, you 
can navigate to a specific MRI slice in that pane by moving the slider, entering 
the slice number in the text box, or by selecting the arrow buttons. You can 
also use the scroll wheel on your mouse. The other two MRI panes will update 
accordingly.

Note: The grid numbers used in GeoSource do not correspond to Talairach Daemon or 
MNI coordinates.

Dipole information area. This area displays roll-over information about the 
dipole that is under the cursor in an MRI pane. The information includes 
dipole ID number, dipole location (in X, Y, and Z coordinates in MNI space), 
intensity in nanoamp meters, and Brodmann area, gyrus name, and lobe name 
(as defined by the Talairach Daemon).

Palette Drawer
The GeoSource Viewer displays the dipoles in colors that represent their intensities. 
The intensity values (including maximum and minimum) correspond to the datapoint 
beneath the Time Synch marker in the Net Station Viewer.

The palette drawer allows you to change the color palettes for the dipoles or to 
navigate directly to a specific dipole based on its dipole ID number or intensity value. 

Figure 2-19. Dipoles in the MRI panes approximately represented by voxels
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General Palette Controls
Figure 2-20 shows the top portion of the palette drawer. To show the palette drawer, 
click the Palette button on the GeoSource Viewer (see Figure 2-18).

The following are brief descriptions of the items in Figure 2-20.

Display. When selected (checked), displays the dipoles that are overlaid onto the 
MRI slices; when unselected (unchecked), hides the dipoles.

Show Orientation Vector. The Show Orientation Vector checkbox displays or 
hides the dipole orientation vectors in the MRI slices. The orientation vectors, 
which are represented by black lines (Figure 2-21), indicate the direction the 
dipole is pointing. They extend in the positive direction from the center of 
each voxel. (Check the checkbox to display; uncheck the checkbox to hide.) 

Transparency slider. This slider increases or decreases the amount of light 
transmitted through the dipoles.

Figure 2-20. General palette controls

Figure 2-21. Orientation vectors

Example of 
orientation vector
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Palette Pane
Click the Palette tab on the palette drawer to select the Palette pane (Figure 2-22). 

The following are brief descriptions of the items in Figure 2-22.

Spectrum pop-up menu. Allows the selection of a color spectrum. To view the 
available spectra, see the “Amplitude-Scale Palette” chapter in the Net Station 
Viewer Technical Manual.

Palette-maximum-slider label. Initially, indicates the default palette maximum. 
You can, however, highlight this value and type a lesser value, which 
decreases the palette maximum and moves the palette-maximum slider 
(item D) downward.

Palette-maximum label. Indicates the current palette maximum, which is a 
setting that is set by the palette-maximum slider (item D).

Palette-maximum slider. When dragged downward, the palette maximum is reset 
to a lesser value, which is reflected in the palette-maximum label (item C).

Figure 2-22. Palette pane
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Palette-range slider. Marks the midpoint between the palette’s maximum and 
minimum values. This slider is not draggable.

Palette-minimum slider. When dragged upward, the palette minimum is reset to 
a greater value, which is reflected in the palette-minimum label (item G).

Palette-minimum label. Indicates the current palette minimum, which is a 
setting that is set by the palette-minimum slider (item F).

Palette-minimum-slider label. Initially, indicates the default palette minimum. You 
can, however, highlight this value and type a greater value, which increases the 
palette minimum and moves the palette-minimum slider (item F) upward.

Lock button. This button, if selected (darkened), makes the palette-slider range 
equal to the data range for the data point under the Time Synch in the Net 
Station Viewer. This feature is useful if you want the data range to remain 
fixed while you navigate through the Net Station Viewer and view the dipoles 
of different time points in the GeoSource Viewer.

Accumulate button. If this button is selected (darkened), the palette maximum 
and minimum values automatically update according to the new time points 
received as the EEG data are played in the Net Station Viewer. In other words, 
whenever a larger maximum or smaller minimum value appears, it becomes 
the new maximum or minimum value for the palette. If this button is 
unselected (not darkened), the palette will report the maximum and minimum 
values for only the current time point.

Palette-range link buttons. Indicates whether the palette range (maximum and 
minimum) of the active window is independent of or linked to the palette 
range of another window.

Master palette button (  ). If this button is selected on the active window, 
the palette of the active window is setting the palette range for another 
window or windows.

Slave palette button (  ). If this button is selected on the active window, 
the palette of the active window is having its palette range set by another 
window.

If neither link button is selected on the active window, there is no linking 
between the active window and other windows, which means that its palette 
range is independent of other windows.
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Intensities Pane
Click the Intensities tab on the palette drawer to select the Intensities pane (Figure 2-
23). The Intensities pane lists the dipoles, organized by label or intensity. Clicking a 
label or an intensity in the Intensities pane automatically navigates the three MRI 
panes in the GeoSource Viewer to the selected dipole. 

The following are brief descriptions of the items in Figure 2-23.

ID column. Lists the dipoles by ID number. Click the column title to sort the ID 
numbers in ascending or descending order. 

Intensity column. Lists the dipoles by intensity value. Click the column title to 
sort the intensity values in ascending or descending order.

Intensity color column. Lists the dipoles by intensity color. Click the column to 
sort the intensity colors in ascending or descending order.

Figure 2-23. Intensities pane
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Flat Map Window
The Flat Map window (Figure 2-24) projects the dipole information onto a smooth, 
two-dimensional representation of the cortical surface. 

The following are brief descriptions of the items in Figure 2-24.

Folds. When selected (darkened), this button displays the borders of the cortical 
folds. This button is selected by default. Click it to deselect it.

Note: The folds are represented by transparent gray lines overlaid on the map, which 
may slightly mask some of the colors of the dipole activations. To see all of the colors of 
the dipole activations, deselect this feature.

Secondary. The 3D-to-2D conversion of the dipoles results in a small number of 
overlapped dipoles. If this button is selected (darkened), the Flat Map window 
displays the average intensity of the overlapped dipoles. If this button is 
unselected (not darkened), the intensity of the topmost dipole is displayed.

Flat map. Provides a two-dimensional representation of the left and right 
hemispheres of the cerebral cortex on which dipole activity is depicted. The 
thin white line indicates the approximate outlines of the lateral surface of each 
hemisphere.

Figure 2-24. Flat Map window
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Dipole information area. Displays roll-over information about the dipole that is 
under the cursor in the Flat Map window. The information includes dipole ID 
number, dipole location (in X, Y, and Z coordinates in MNI space), intensity in 
nanoamp meters, Brodmann area, gyrus name, and lobe name (as defined by 
the Talairach Daemon).

GeoSource Menus

The GeoSource menu bar is visible when a GeoSource Viewer, which is for the MRI 
source-viewing mode, is frontmost on the monitor screen.

Note: Which viewer (Net Station or GeoSource), menus, and options are available onscreen is 
determined by the space (source or scalp), view (chart, grid, etc.), category-viewing mode (as 
continuous data, etc.), and source-viewing mode (waveforms or MRI) of the currently open file or 
view (if not yet saved as a file). For details, see “What to Know Before Getting Started” on 
page 54.

Figure 2-25 shows the GeoSource menu bar.

The following GeoSource menus enable these functions:

• GeoSource menu. Sets the GeoSource Viewer preferences.

• File. Opens and closes GeoSource files.

• Edit. Selects, copies, and pastes source data within and between files.

• Window menu. Zooms in on a GeoSource Viewer or brings all active GeoSource 
Viewers to the front.

• Source Montages menu. Creates or edits source montages, or applies source
montages to the source data in the GeoSource Viewer.

Figure 2-25. GeoSource menu bar
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GeoSource > Preferences
The GeoSource menu allows you to set the orientation of the MRI panes by choosing 
GeoSource > Preferences (Figure 2-26). 

The following is a brief description of the items in Figure 2-26.

Image Orientation. Allows you to view the dipoles on the MRI slices in one of 
two orientations (or views), as follows.

L = L and R = R. Displays left on the left and right on the right.

Radiological|L=R R=L. Displays left on the right and right on the left.

Flatmap background color. Allows you to set the color that is displayed behind 
the flatmap. Black is the default.

Orientation vector color. Allows you to set the color of the orientation vectors. 
Black is the default.

Always Keep GeoSource on Top. When checked, allows you to set the GeoSource 
Viewer to display on top of all other open windows or dialogs.

Figure 2-26. GeoSource menu and GeoSource Preferences window
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Window Menu
The Window menu (Figure 2-27) allows you to organize the viewing order of the 
GeoSource Viewer windows. You can also use the GeoSource icon in the Dock to 
easily distinguish between many open files by right clicking the GeoSource icon in the 
Dock and seeing a full description of each file. 

The following are brief descriptions of the items in Figure 2-27.

Minimize. Reduces the frontmost GeoSource Viewer to an icon and places it in 
the Dock to save screen space. (Clicking the yellow Minimize button in the 
top-left corner of the GeoSource Viewer achieves the same result.)

Zoom. Enlarges the frontmost GeoSource Viewer to full screen size.

Bring All to Front. Places all GeoSource Viewers in front of all other application 
windows.

Names of GeoSource viewers. Brings the selected GeoSource Viewer to the front 
of all other windows. 

Source Montages Menu
The Source Montages menu (Figure 2-28) allows you to apply, create, or edit a source 
montage (i.e., a subset of the dense dipole solution set, which is a region of interest).

The editing functions are available only for a currently applied source montage. You 
can delete, edit, or clone the source montage:

• If you choose Delete Montage, a confirmation dialog will appear.

Figure 2-27. Window menu
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• If you choose either Edit Montage or Clone Montage, you can rename the
montage, rename dipole groups, or add or delete dipole groups from the
selected montage, but you cannot change the radius distance or the threshold
percentage values (see “4. Dipole-group creation buttons” on page 51). Note
that cloned montages must be saved under a different name than the original.

Choosing Source Montages > New Montage, Source Montages > Edit Montage, or 
Source Montages > Clone Montage opens the Source Montage Editor window 
(Figure 2-29). The Source Montage Editor window allows you to populate source 
montages using a variety of dipole-group creation methods. 

Figure 2-28. Source Montages menu when a montage is
not applied (left) and when it is (right)

Figure 2-29. Source Montage Editor window

Available commands if 
no montage is applied

Available commands if 
a montage is applied 
(the delete, edit, and 
clone functions apply to 
the current montage)
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The following are brief descriptions of the items in Figure 2-29.

Montage Name. Allows you to type in a name for the montage.

Names of dipole groups. Lists the name and the icon for the dipole-group creation 
method of each dipole group, which is populated after you click a dipole-group 
creation button and click a voxel in an MRI pane of the GeoSource Viewer. Note 
that a dipole group represents one dipole in a source montage.

Members of selected dipole group. Lists the number of dipoles, the icon and 
parameters of the dipole-group creation method, and the dipole ID numbers 
for each dipole group. This table is populated after you click a dipole-group 
creation button and click a voxel in an MRI pane of the GeoSource Viewer, or 
after you select an existing dipole group in the dipole-group names table.

Dipole-group creation options. Click to select a dipole-group creation method. 
Options are:

Selected. Allows you to click or Shift-click individual voxels in the MRI panes 
to populate a dipole group. 

Radius. Allows you to first specify a radius for a dipole group (Figure 2-30), 
and then click a voxel in the MRI panes. All voxels that fall within that radius 
from the selected voxel will populate the dipole group. 

Threshold. Allows you to first specify a percentage-of-peak value (Figure 2-
31), and then click a voxel in the GeoSource Viewer. All adjacent voxels with 
intensities that fall within the specified percentage of the selected voxel’s will 
populate the dipole group. 

Figure 2-30. Radius parameters

Figure 2-31. Threshold parameters
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Dipole Name. Allows you to type in a name for a dipole group whose voxels 
were individually selected or set by a radius or threshold setting. It is 
recommended that you assign a meaningful name that is indicative of a dipole 
group’s anatomical location (such as amygdala) or indicative of the time point 
at which it occurred (such as P300).

Append Dipole Number to Name. When selected (checked), this checkbox 
automatically appends a dipole number to the name of the dipole group. The 
number appended is the number of the voxel that was first selected (clicked) 
to set the group. 

Accept and Cancel. Whereas Accept saves all changes while closing the window, 
Cancel closes the window without saving changes. 
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CHAPTER 3GETTING STARTED

his chapter begins with what you need to know before getting started. With that 
understanding, the chapter then describes the basic tasks that are needed to apply 

a default source-imaging specification to a Net Station EEG scalp data file. Applying a 
source-imaging specification will allow you to:

• display source data in the Net Station Viewer or the GeoSource Viewer;

• view source data in the Net Station Viewer as the RMS (root-mean-square) of
the source components or as overlaid source components; or

• navigate through source data in the Net Station Viewer and view the source
data for the different time points in the GeoSource Viewer and the
corresponding flat map in the Flat Map Window.

Note: GeoSource can be applied to any Net Station file that does not contain
bipolar channels. Bipolar channels are not supported for source estimation. A
warning dialog will appear if you mistakenly apply GeoSource to a file that does

contain bipolar channels. If your file has the  icon next to the channel numbers, 
then it contains bipolar channels. Use another file.

The chapter goes on to describe the following user tasks:

• How to create a source montage in the GeoSource Viewer.
• How to edit, clone, or delete a source montage.
• How to create a source-imaging specification.
• How to edit, clone, or delete a source-imaging specification.
• How to create a GeoSource specification.

This chapter concludes with a list of basic user tips.

For descriptions of the GeoSource controls, see Chapter 2, “GeoSource Menus 
and Windows.” For explanations or definitions of unfamiliar terminology, see 
Chapter 4, “Source-Imaging Specifications” or the "Glossary.”

T
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What to Know Before Getting Started

Since Net Station can display GeoSource source waveforms, it is important that you 
know when you are using a Net-Station-formatted file (an EEG scalp data file) and 
when you are using a GeoSource-formatted file (a source data file). An EEG scalp data 
file can display data in various waveform, topographic, and synoptic plot views. A 
source data file can display either source waveforms in the Net Station Viewer (but 
only in the chart, grid, or synoptic plot views), or source MRI slices in the GeoSource 
Viewer. 

One reason why you need to know when you are using what type of file is that some 
of the Net Station windows and dialogs display different fields and options 
depending upon whether a scalp data file or a source data file is currently open. 
Another reason for distinguishing your files is that the scalp data waveform files and 
the source data waveform files are both viewed with the Net Station Viewer. 
Therefore, as you put more files on the screen that may look similar, it becomes more 
important to ensure that you manage your files carefully.

Scalp Data Files versus Source Data Files
Here are the distinguishing characteristics between scalp and source data files.

Table 3-1. Distinguishing characteristics between scalp data files and source data files

Distinguishing 
characteristics Scalp data files Source data files 

(including waveforms and MRI slices)

file icon
Net Station MFF file icon GeoSource file icon

Net Station windows and dialogs will 
display complete lists of fields and options.

Net Station windows and dialogs will 
display only those fields and options 

that pertain to GeoSource operations.

file extension

File format Default extension File format Default extension

original Net Station 
session EEG MFF 

recording file

None, but Net Station 
does read original 

EEG recording files as 
having the .mff 

extension, since they 
are session files.

Net Station MFF 
Recording file .mff

Net Station 
Recording file .ses

Source Binary File .swf

Tab-delimited Text .txt

MATLAB .mat
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Creating a Source Data File
Note that once a set of parameters (source-imaging specification and source-viewing 
mode) is established for a GeoSource file, you cannot change those parameters for that 
saved file. You can, however, go back to the Net Station EEG scalp data file and save a 
series of GeoSource files from that original EEG data file with different sets of 
parameters.

Note: GeoSource will localize all scalp-recorded activity to dipoles distributed across the 
cortical gray matter. It is, therefore, important for the scalp data to be as artifact free as 
possible. This is accomplished through careful data acquisition followed by postprocessing to 
identify and correct/remove artifact-contaminated trials and channels.

CAUTION: The following steps are provided as a quick reference only. To avoid 
corrupting files or data, read all material in this manual before proceeding.

To convert a Net Station EEG scalp data file into a GeoSource source data file, do 
the following:

1 Open a scalp data file in Net Station.

2 Open the GeoSource Controls window by choosing GeoSource > GeoSource 
Controls.

3 Establish the desired GeoSource parameters for the file to be converted by:

a Choosing a source-imaging specification (default or user-defined). For 
details, see page 36 and page 88.

b Choosing a source-viewing mode (waveforms or MRI). For details, see 
page 35.

Note that by choosing one source-viewing mode or the other that a new 
source view of the EEG data is generated. What is displayed, however, is 
only a view. It is not yet a file.

channel or dipole icon
single-channel icon bipolar-channel icon dipole icons 

listed montages only defaults (including 10-20) user-defined and two defaults 
(including Gyri)

amplitude scale (unit) μV nA

window title 
(before view saved) filename : window # filename : window # : name of source-

imaging specification

Table 3-1. Distinguishing characteristics between scalp data files and source data files
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4 Save the entire view or a selection of the view as a source data file (in waveform 
view) by:

a Choosing File > Save Selection [or Save A Copy As].

b Typing a new filename and extension into the Save As text box or leaving 
the default as is.

Note that you can customize the extensions (that is, not use the defaults) 
of Net Station and GeoSource files. Also note that the default file 
extensions change as you select a different format from the Format pop-
up menu.

c Using the Where pop-up menu to tell the software where to save the 
new file.

d Choosing a file format from the Format pop-up menu. For details, see 
page 24.

e Choosing an output option from the Output Precision pop-up menu. For 
details, see page 25.

f Click Save As. Notice that the saved file now has the GeoSource file icon.

Note: Both the Convert to Microvolts and Apply Viewer Transformations checkboxes will 
default as appropriate and are never selectable.

Displaying Source Data in the Net Station 
Viewer or the GeoSource Viewer

The configuration of the scalp data in the Net Station Viewer can affect how the source 
data are displayed in the Net Station Viewer and in the GeoSource Viewer. Therefore, 
before applying GeoSource to a Net Station EEG scalp data file:

• Regarding bipolar channels, make sure that the file does not contain them.
Bipolar channels are not supported for source estimation. If your file has the

 icon next to the channel numbers, then it contains bipolar channels. Use 
another file. 

• Regarding display views, know that although GeoSource can be applied to any
Net Station EEG scalp data file that does not contain bipolar channels,
regardless of its view (chart, grid, topo plot, synoptic plot, or topo map) or
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category-viewing mode (as continuous data, categories, or overlaid segments), 
the Net Station Viewer can display source data in only a chart, grid, or synoptic 
plot view. 

Note: Be aware that scalp data that are displayed in a topo plot or topo map view will 
be displayed in a chart view when converted to source data.

• Regarding filters, know that any filter applied to scalp data in the Net Station
Viewer will be applied in the conversion to source data. Furthermore, the Net
Station Viewer IIR filter should be used for exploration purposes only. Finally, if
you wish to source analyze filtered data, be sure to first filter your scalp file
using the filtering Waveform Tool. For details about filters, see the Net Station
Viewer Technical Manual.

• Regarding category-viewing modes, make sure that you select your mode
carefully. The category-viewing mode selected in the Net Station Viewer for the
scalp data affects the display of the source data in the GeoSource Viewer.
Furthermore, if you change from viewing the scalp data file as categories to
overlaid segments (or vice versa), the GeoSource Viewer will close and you will
be required to regenerate the source data with your desired source-imaging
specification. For details about the category-viewing modes, see the Net Station
Viewer Technical Manual.

• Regarding optimum viewing (category-viewing mode and display views),
typically, configuring the scalp data as overlaid segments in topo map view
(potentials, full projection) works well, because it allows the user to view
multiple conditions simultaneously in GeoSource and to more easily relate the
source solution at a given time point to the scalp topography.

The following instructions describe how to use a default source-imaging specification 
to display source data in the Net Station Viewer (see page 21) or in the GeoSource 
Viewer (see page 39).

To display source data in both viewers, do the following:

1 Open the GeoSource Controls window by opening a Net Station EEG scalp data 
file, configuring the Net Station Viewer as described above, and choosing 
GeoSource > GeoSource Controls (Figure 3-1).

Note: This GeoSource Controls window provides source-imaging functions only for its 
corresponding Net Station EEG file. If you wish to view the source data of another Net 
Station EEG file, you must open a separate GeoSource Controls window from within that 
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file. The name of the corresponding Net Station EEG file is displayed at the top of each 
GeoSource Controls window (see page 34).

2 Click a default source-imaging specification to select it. See Figure 3-2.

Figure 3-1. Opening the GeoSource Controls window

Figure 3-2. Selecting a default source-imaging specification and viewing option

Select a source-
imaging

specification

Select a dipole set

Select a GeoSource
viewing option

GeoSource contains these three default source-
imaging specifications (LAURA, LORETA, and 
sLORETA). For instructions on how to create your own 
specification, see page 88.
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3 Select a GeoSource viewing option in the GeoSource Controls window 
(Figure 3-2).

The viewing options are View as Waveforms and View in MRI:

• View as Waveforms. The resulting source waveforms will be displayed in 
a second Net Station Viewer window in a chart, grid, or synoptic plot
view (Figure 3-3). If the scalp data are configured in a topo plot or topo
map view, the source data will display in a chart view.

Figure 3-3. Scalp data (top) and source data (bottom) in the Net Station Viewer

Scalp data displayed
as overlaid segments

in a chart view

Source data displayed
in the same format

(as overlaid segments
in a chart view)
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• View in MRI. The resulting source data is displayed in the GeoSource
Viewer projected onto MRI slices. If the scalp data are configured as
overlaid segments in the Net Station Viewer, then the source data will
display in a separate GeoSource Viewer for each category (Figure 3-4).

Whether the source data are displayed in the Net Station Viewer (as waveforms) or in 
the GeoSource Viewer (as MRI slices), all active windows remain open on the desktop. 
This allows you to: 

• Easily view the data from different perspectives—as scalp data, as source
waveforms, or as dipoles in the GeoSource Viewer.

• Add more windows by choosing different source-imaging specifications in the
GeoSource Controls window for side-by-side comparisons of the results.

Note: GeoSource labels these windows with the Net Station EEG filename and inverse
method, and numbers them sequentially.

Figure 3-4. Source data in the GeoSource Viewer (right), along with scalp data in the 
Net Station Viewer (upper left) and the corresponding GeoSource Controls window (lower left)

A GeoSource Viewer for the
Standard Correct category

A GeoSource Viewer for the Target
Correct category

Lists active source data windows
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• Apply viewer transformations to a copy of the scalp data (created by choosing
View > Open New Window), and view the effect on the source data in the
GeoSource Viewer by cycling through the different EEG windows in the Data
From column of the GeoSource Controls window (for more information, see
page 35).

Viewing Source Data as RMS or as Overlaid 
Components in the Net Station Viewer

Each dipole consists of three orthogonal 
orientations representing X, Y, and Z. In the 
Net Station Viewer, GeoSource allows you to 
view all three orientations for each dipole (as 
overlaid source components) or to view one 
collapsed waveform that represents the RMS of the 
three orientations combined (as RMS of source 
components). For details, see page 31.

Note: It is not possible to view all 2,447 dipole sources 
as waveforms in the Net Station Viewer. When a dense 
montage is selected, 47 representative dipoles are 
displayed. To display the waveforms of other dipoles (or dipole groups), you can create a user-
defined source montage (see page 77).

To view the source waveforms in either representation, the Net Station Viewer must 
be in the chart or grid view. It can be in any of the category-viewing modes. 

1 View GeoSource source waveforms in the Net Station Viewer. (If necessary, 
refer to steps 1 through 3 starting on page 56 in “Displaying Source Data in the 
Net Station Viewer or the GeoSource Viewer” to convert the scalp waveforms.) 
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2 With the source waveforms in the Net Station Viewer, choose View > as RMS of 
Source Components to view the component waveforms collapsed into a single 
waveform (Figure 3-5). 

3 With the source waveforms in the Net Station Viewer, choose View > as 
Overlaid Source Components to view the three orientations for each dipole 
(Figure 3-6). 

Figure 3-5. Source waveforms displayed as the RMS of the source components

Figure 3-6. Source waveforms displayed as overlaid source components
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Almost all the file export formats (Net Station MFF recording, Net Station recording, 
source binary, tab-delimited text, and MATLAB) save source data as all three source 
components. The one exception is the source binary format, which can save source 
data as either one or three components. If you save the source data to a Net Station 
recording file from the Net Station Viewer, make sure that the data are displayed in 
the desired configuration.

Navigating through the GeoSource Viewer via 
the Net Station Viewer

Corresponding files in the Net Station Viewer (scalp data file) and the GeoSource 
Viewer (source data file) are automatically linked. However, whereas the Net Station 
Viewer contains data for an entire recording session or segment, the GeoSource 
Viewer does not. The GeoSource Viewer displays source data only for the time 
indicated by the Time Synch marker in the Net Station Viewer. Therefore, to navigate 
through the time of the source data in the GeoSource Viewer, you must navigate 
through the waveforms of the scalp data in the linked Net Station Viewer. 

Because many scalp waveform data files may be open in the Net Station Viewer at the 
same time, make sure that you are navigating in the file that is actually providing the 
data to the GeoSource Viewer. 

• The corresponding window designation will be displayed in the Data From text
box in the GeoSource Viewer and in the Data From column of the GeoSource
Controls window (Figure 3-7).

• If you are viewing data as categories in the Net Station Viewer, then simply
progress to the next category to see it displayed in the GeoSource Viewer.

• If you are viewing data as overlaid segments, then the categories displayed in
the Net Station Viewer will open in separate GeoSource Viewers, and the
category name will be specified in the Data From text box.

• If you change the categories being viewed in the Net Station Viewer, then the
corresponding GeoSource Viewer will be updated with the new category.
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Navigating Through Linked Files with Net Station in 
Chart View

To navigate through linked files in the Net Station Viewer, while in chart view, and the 
GeoSource Viewer, you must use the Time Sync button and do the following:

1 View the source data in the GeoSource Viewer. (If necessary, refer to steps 
1 through 3 starting on page 56 in “Displaying Source Data in the Net Station 
Viewer or the GeoSource Viewer” to convert the scalp waveforms.)

2 Reveal the time synchronization information in the Net Station Viewer (Figure 3-8):

a Select the Time Synch button in the data-display control strip to display 
the Time Synch marker (the vertical line) in the waveform pane.

Figure 3-7. Navigating through the scalp waveforms in the Net Station Viewer
that are supplying the data for the source MRI slices in the GeoSource Viewer

In this figure, to view the 
source data at different 
time points in the 
GeoSource Viewer, you 
must navigate in 
Net Station Viewer 
Window 3. 

GeoSource Viewer GeoSource Controls

Net Station Viewer

(Window 3 is this file)



Chapter 3: Getting Started

65GeoSource 2.0 Technical Manual  8103101-52 • March 9, 2015

b Click the Time Synch toggle in the status bar until the Time Synch icon is 
displayed. The Time Synch icon displays the point in time that is marked 
by the Time Synch marker. 

3 Drag the Time Synch marker (in the Net Station Viewer) to the desired time 
point in the waveform pane (Figure 3-8). Note that the time displayed in the 
Time text box of the GeoSource Viewer changes accordingly (Figure 3-9).

Figure 3-8. Navigating through linked files in the Net Station Viewer (chart view)
and the GeoSource Viewer

Time Synch button in the data-
display control strip that displays 
the Time Synch marker in the 
waveform pane

Time Synch icon (one of the icons 
of the Time Synch toggle) in the 
status bar that displays the point 
in time that is marked by the 
Time Synch marker

Time 
Synch 
marker

Notice that the time displayed in 
the Time text box of the 
GeoSource Viewer is the same 
as the time displayed in the 
status bar of the Net Station 
Viewer.

Net 
Station 
Viewer

GeoSource 
Viewer



Chapter 3: Getting Started

66 GeoSource 2.0 Technical Manual  8103101-52 • March 9, 2015

4 Move to a different time point by dragging the Time Synch marker or using the 
navigation buttons. The GeoSource Viewer will update at each time point to 
show you the dipole activation in specific regions of the brain over time.

Note: If the GeoSource Viewer does not navigate in synch with the Net Station Viewer, 
double-check that you are navigating in the correct scalp waveform and that the link icon 
is present in the GeoSource Controls window.

Navigating Through Linked Files with Net Station in 
Topo Map View

To navigate through linked files in the Net Station Viewer, while in topo map view, 
and the GeoSource Viewer, simply use the navigation buttons in the Net Station 
Viewer. See Figure 3-9.

The dipole activations will correspond to the time window displayed in the topo map 
view, and clicking the play button will initiate a movie of changing activations in 
specific brain regions over time.

OBSERVATIONS:  Observe the relationship between the source solution and the scalp 
topography. Look for brain regions and orientations that would volume conduct to produce 
your major scalp landmarks. Figure 3-9, for example, shows the source solution at 167 ms, 
the peak of the visual N1 component. The bilateral posterior negativities are likely 
generated by activity in the left and right fusiform gyrus, Brodmann Area 37. The MRI 
Viewer clearly shows high intensity activity in these regions. The orientation vectors, which 
point in the positive direction from the center of a dipole voxel, indicate that this dipolar 
activity is projecting surface-positive toward the front and top of the head, where the topo 
plot shows a broad positivity, and surface-negative on the left and right lateral inferior-
posterior surface, where the topo plot shows focal negativities. 
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Figure 3-9. Navigating through linked files in the Net Station Viewer (topo map view)
and the GeoSource Viewer

Corresponding files in the 
viewers are automatically linked 
so that moving the Time Synch 
marker in the Net Station Viewer 
will cause the GeoSource Viewer 
to move to the same time point, 
or that playing through the data 
in the Net Station Viewer will 
allow you to view the dipole 
activations developing over time 
in the GeoSource Viewer.

Navigation buttonsNavigation buttons

Scalp N1 component

Corresponding brain source for
the scalp N1 component
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Navigating to a Specific Dipole in the GeoSource 
Viewer Using the Palette Drawer

The ability to navigate directly to a specific dipole is useful if you wish to add it to or 
delete it from a source montage (described later on page 77) or just examine it and the 
surrounding dipoles more closely. The palette drawer of the GeoSource Viewer is 
designed specifically for this type of navigation—to allow you to find a dipole by its 
ID number or intensity value. 

The palette drawer also allows you to define the color spectrum that represents the 
dipole intensities. Instructions on how to define the color spectrum are provided in 
the “Amplitude-Scale Palette” chapter in the Net Station Viewer Technical Manual. 

This section describes how to navigate to a specific dipole and to view information 
about it in the GeoSource Viewer.

To navigate to a specific dipole using the palette drawer, do the following:

1 View the source data in the GeoSource Viewer. (If necessary, refer to steps 
1 through 3 starting on page 56 in “Displaying Source Data in the Net Station 
Viewer or the GeoSource Viewer” to convert the scalp waveforms.)

2 Open the palette drawer by clicking the Palette button in the GeoSource Viewer 
(Figure 3-10).

Figure 3-10. Opening the palette drawer
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3 In the palette drawer, click the Intensities tab (Figure 3-11).

4 The column titles in the palette drawer serve as toggles to sort the columns by 
ascending or descending order. Click a title (for example, the Intensities column 
title) once to change the direction of the order (ascending or descending), and 
click it again to change it back. The sorting order is indicated by the direction of 
the arrow next to the column title (Figure 3-12).

Figure 3-11. Viewing the palette intensities

Figure 3-12. Sorting the dipoles by order of intensity

Arrow indicates
order (ascending
or descending) of
column’s contents
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5 Now, click the ID column’s title once to change the direction of the sorting order 
(ascending or descending) of its contents, and click it again to change the order 
back (Figure 3-13).

6 To navigate the three MRI panes in the GeoSource Viewer directly to a specific 
dipole, click one of the dipole numbers in the ID column of the Intensities pane of 
the palette drawer. To find a desired dipole that is not visible in the Intensities 
pane, drag the scroll bar that is on the right side of the palette drawer.

7 Roll the cursor over a dipole in the MRI slices to display dipole information at 
the bottom of the GeoSource Viewer. The information includes the dipole’s ID 

Figure 3-13. Sorting the dipoles by order of ID number
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number, location (X, Y, and Z coordinates in MNI space), intensity in nanoamp 
meters, Brodmann area, gyrus name, and lobe name (Figure 3-14). 

Navigating to a Specific Dipole in the GeoSource 
Viewer Using a Focus Pane

Another way to navigate through the GeoSource Viewer is to use a focus pane. This 
feature updates the other two MRI panes relative to the changes made in the focus 
pane. A focus pane is created by clicking one of the three MRI panes. The white 
crosshairs of the pane selected to be the focus pane will turn yellow. 

To navigate when using a focus pane, do any of the following:

• Point. Click anywhere in the focus pane and all three MRI panes will
automatically center their crosshairs relative to the clicked point.

• Crosshairs. Drag the crosshairs anywhere in the focus pane and all three
MRI panes will automatically center their crosshairs relative to the dragged
crosshairs.

• MRI slice slider. Drag the MRI slice slider beneath the focus pane and all three
MRI panes will automatically center their crosshairs relative to the MRI slice
under the slider.

Figure 3-14. Cursoring over a specific dipole in the GeoSource Viewer and displaying information about it
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• MRI slice text box. Type in an MRI slice number in the text box beneath the
focus pane and all three MRI panes will automatically center their crosshairs
relative to that slice number.

• MRI slice arrow buttons. Select the arrow buttons beneath the focus pane and
all three MRI panes will automatically center their crosshairs relative to the
selected slice.

• Scroll wheel. Roll the scroll wheel with the cursor over one of the panes (the
crosshairs will turn yellow if they were white). All three MRI panes will
automatically center their crosshairs relative to the scrolling point.

Note: The MRI slice sliders and text boxes are designed to navigate to a specific MRI slice, not 
to a specific dipole or dipole ID number.

Note: The MRI slice numbers correspond to the GeoSource grid, not Talairach or MNI space. To 
know the corresponding coordinate in MNI space, refer to the dipole information at the bottom 
of the GeoSource Viewer. To know the coordinate in Talairach space, convert the MNI 
coordinate to Talairach (e.g., MNI2TAL).

Navigating in the Flat Map Window and 
the GeoSource Viewer

A flat map in the Flat Map window is useful for viewing dipole activations over the 
entire cortex, not just in the MRI slices currently displayed in the GeoSource Viewer. 
The Flat Map window and the GeoSource Viewer are linked, so navigating in one 
automatically causes the other to synchronize its view. The Flat Map window and the 
Net Station Viewer are also automatically linked so that when the Net Station Viewer 
is set to play through a scalp waveform file, the Flat Map window allows you to view 
dipole activations as they evolve over time.

To create a flat map of a file in the GeoSource Viewer, do the following:

1 View the source data in the GeoSource Viewer. (If necessary, refer to steps 
1 through 3 starting on page 56 in “Displaying Source Data in the Net Station 
Viewer or the GeoSource Viewer” to convert the scalp waveforms.)

2 Click the Flat Map button, which opens a second window that displays the 
dipole information projected onto a two-dimensional representation of the left 
and right hemispheres of the cerebral cortex. Like the GeoSource Viewer, at the 
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bottom of the Flat Map window is a dipole information area that displays the 
ID number, location (X, Y, and Z coordinates in MNI space), intensity in 
nanoamp meters, Brodmann area, gyrus name, and lobe name of the dipole 
currently under your cursor (Figure 3-15). 

Figure 3-15. Clicking the Flat Map button for a two-dimensional cortical view of the dipoles

GeoSource Viewer
window

Flap Map
window
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Figure 3-16 shows a larger view of the Flat Map window. To aid in orienting the 
user to the flat map, a thin while line roughly outlines the edge of the lateral 
surface of the brain. The regions outside this line correspond to the medial 
surfaces of each hemisphere (unwrapped and flattened). The Folds and 
Secondary buttons are both selected by default. These features are 
demonstrated in the following steps. 

3 Click anywhere in the flat map of the Flat Map window, and the GeoSource 
Viewer will automatically navigate to that point in the MRI slices. See 
Figure 3-15. Vice versa—click anywhere in the MRI slices of the GeoSource 
Viewer, and the Flat Map window will automatically navigate to that point in 
the flat map. 

Figure 3-16. A flat map in the Flat Map window with both default settings (Folds and Secondary) selected
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4 Click the Folds button to deselect it (Figure 3-17). Notice that the light gray 
mottling that represents the cortical folds disappears. Click the Folds button 
again to again display the cortical folds as shown in Figure 3-16.

5 Click the Secondary button to deselect it. See Figure 3-18. Notice that the colors 
of some small regions of the flat map have changed. Because these small 
regions contain overlapped dipoles (as a result of the 3D-to-2D conversion of 
the dipoles), the Flat Map window uses different dipoles to represent them.

• When the Secondary button is selected, the Flat Map window displays
the average intensity of the overlapped dipoles.

• When the Secondary button is deselected, the Flat Map window displays
the intensity of the topmost dipole.

Click the Secondary button again to again display the average intensity of these 
small regions as shown in Figure 3-16. 

Figure 3-17. A flat map that is not displaying the light gray mottling of the cortical folds because 
the Folds button is deselected
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6 Arrange the Net Station Viewer with its scalp waveform, the GeoSource Viewer 
with its MRI slices, and the Flat Map window with its flat map on the desktop 
so that you can easily view all three.

7 In the scalp waveform file of the Net Station Viewer, open the navigation 
control strip, then click one of the navigation buttons (see Figure 3-9) to play 
through the file.

As the EEG scrolls temporally in the Net Station Viewer, the dipole activations 
will appear in the GeoSource Viewer and the Flat Map window, which are 
complementary viewing tools. When these two GeoSource views (MRI slices 
and flat map) and the Net Station view (such as the topo map or chart view) are 
viewed together, they can provide a comprehensive view of the estimated 
source activity. 

Figure 3-18. A flat map that has changed the display of the overlapped dipoles from average intensity to topmost 
because the Secondary button is deselected
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Built-in Source Montages

GeoSource provides two built-in source montages: BAs and Gyri. The BAs source 
montage groups individual dipoles into groups that correspond to Brodmann Areas. 
The Gyri source montage groups dipoles by the major brain gyri (e.g., fusiform gyrus).

GeoSource also allows you to create your own source montages made up of groups of 
dipoles specific to your own regions of interest. The following section (“Creating a 
Source Montage in the GeoSource Viewer”) steps you through the process.

Creating a Source Montage in the 
GeoSource Viewer

A source montage allows you to highlight only the source data that is of interest. You 
can export this subset of data to another file using the File > Save commands (see 
page 23) or a GeoSource specification (see page 25). 

If you save out individual subject average files as source waveform files using a source 
montage, you can then use these files in the Statistics Extraction tool to extract values 
for statistical analyses in time windows and brain regions of interest across conditions 
or subject groups.

Source montages can be created only in the GeoSource Viewer. The dipoles in the 
GeoSource Viewer are approximately represented by voxels, which are colored 3D 
volume pixels. A dipole group represents one compound dipole in a source montage 
(computed as the mean intensity of the dipoles included in the group). See page 41 
and page 51. Once created, source montages are available in either the GeoSource 
Viewer or the Net Station Viewer for any source data file. 

To create a source montage, do the following:

1 View the source data at your time point of interest in the GeoSource Viewer. (If 
necessary, refer to steps 1 through 3 starting on page 56 in “Displaying Source 
Data in the Net Station Viewer or the GeoSource Viewer” to convert the scalp 
waveforms.)

Note: If desired, you can navigate to different time points of interest as you create 
different dipole groups within user-defined source montages.
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2 To make the spatially discrete areas of the MRI slices more obvious, you can 
reduce the number of low-intensity voxels that are showing. A good starting 
point is to reduce the palette maximum by approximately 20% to highlight the 
higher intensity voxels. To reduce the number of low-intensity voxels, raise the 
palette-minimum slider (see page 43). 

3 In the GeoSource Viewer, choose Source Montages > New Montage from the 
GeoSource menu bar (Figure 3-19). 

4 After the Source Montage Editor window opens (see page 50), notice that the 
voxels in the MRI panes of the GeoSource Viewer are now empty so that they 
may be easily selected for a user-defined source montage. In the Source 
Montage Editor window, type in a name for this user-defined source montage 
and type in a name for the first (or only) dipole group to be included in the 
montage. See Figure 3-20.

Figure 3-19. Reducing the palette maximum to reduce the number of low-intensity voxels, and then
opening the Source Montage Editor window



Chapter 3: Getting Started

79GeoSource 2.0 Technical Manual  8103101-52 • March 9, 2015

The next few steps will step you through creating the one or more dipole 
groups for this source montage via the selected, radius, or threshold dipole-
group creation methods. 

5 If you want to include a dipole group that is defined using the selected dipole-
group creation method, click the Selected button. Then, manually select voxels 
to populate the dipole group. Do so by clicking or Shift-clicking them in the 
MRI panes of the GeoSource Viewer. Clicking starts a new dipole group with 
the clicked voxel and Shift-clicking adds voxels to the current dipole group.

The dipole-group table updates to indicate the method (by method-specific icon), 
dipole-group name, dipole ID numbers, and the number of dipoles that are 
included in the current dipole group being created and added to the source 
montage. See Figure 3-21. When naming dipole groups, it is recommended that 
you assign meaningful names that are indicative of each group’s anatomical 
location (such as amygdala or OFC for orbitofrontal cortex) or indicative of the 
time point at which each occurred (such as P300).

Note: The anatomical names of regions are visible at the bottom of the GeoSource 
Viewer window as you pass your cursor over the three MRI panes.

Figure 3-20. Windows for creating a new source montage—the Source Montage Editor window (right) and 
the GeoSource Viewer (left)
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6 If you want to include a dipole group that is defined using the radius dipole-
group creation method:

a Click the Radius button. 

b In the Radius text box, specify a distance from the voxel that will be 
selected in step c to include in the group. 

c Click a voxel in the MRI panes of the GeoSource Viewer. All voxels that fall 
within the specified radius of the voxel selected will be added to the group.

The dipole-group table updates to indicate the method (by method-specific icon), 
dipole-group name, dipole ID numbers, and the number of dipoles that are 
included in the current dipole group being created and added to the source 
montage. See Figure 3-22. Again, when naming dipole groups, it is recommended 
that you assign meaningful names that are indicative of each group’s anatomical 
location (such as amygdala or OFC for orbitofrontal cortex) or indicative of the 
time point at which each occurred (such as P300).

Note: The anatomical names of regions are visible at the bottom of the GeoSource 
Viewer window as you pass your cursor over the three MRI panes. 

Figure 3-21. Using the selected method for creating a dipole group

Method

Number of 
dipoles

Dipole ID 
numbers

Dipole-group 
name
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7 If you want to include a dipole group that is defined using the threshold dipole-
group creation method:

a Click the Threshold button. 

b In the Percent of Peak text box, specify a percentage of the intensity of the 
voxel that will be selected in step c to be used for including adjacent 
voxels in the group. 

Note: In lieu of a predetermined threshold, 80% is typically a good threshold to 
start with.

c Click a voxel in the MRI panes of the GeoSource Viewer. All adjacent 
voxels with intensities that fall within the specified percentage of the 
voxel selected will be added to the group.

The dipole-group table updates to indicate the method (by method-specific icon), 
dipole-group name, dipole ID numbers, and the number of dipoles that are 
included in the current dipole group being created and added to the source 
montage. See Figure 3-23. Again, when naming dipole groups, it is recommended 
that you assign meaningful names that are indicative of each group’s anatomical 
location (such as amygdala or OFC for orbitofrontal cortex) or indicative of the 
time point at which each occurred (such as P300).

Note: The anatomical names of regions are visible at the bottom of the GeoSource 
Viewer window as you pass your cursor over the three MRI panes.

Figure 3-22. Using the radius method for creating a dipole group

Method for 
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8 If you want to include more than one dipole group in your user-defined source 
montage, complete or repeat any one or more of the steps between step 5 and 
step 7 as often as is necessary.

9 Click the Accept button to save the dipole groups to your new user-defined 
source montage.

10 After a new source montage has been accepted (i.e., created), the GeoSource 
Viewer will automatically display it. To view all voxels again, choose Source 
Montages > None. To reapply a source montage to the GeoSource Viewer, 
choose Source Montages > {montage name}. 

Only the voxels and the names of the dipole groups that are included in a 
source montage are highlighted in the MRI panes of the GeoSource Viewer 
when a source montage is selected. See Figure 3-24.  

Figure 3-23. Using the threshold method for creating a dipole group

OBSERVATIONS:  Notice that each dipole group of a source montage is displayed 
as a composite dipole with three vectors. Also notice that the length of each vector 
indicates the intensity of the corresponding dipole’s orientation in the X, Y, and Z 
planes. The vectors point in the positive direction of the dipolar activity. In orthogonal 
slice views, only two of the three vectors are visible (Figure 3-24). For example, the 
coronal slice view shows vector orientation strengths in the X and Z directions. 
To view the vectors more clearly, you may need to toggle off the crosshairs. 
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11  You can apply the same source montages that you have been using for the MRI 
slices in the GeoSource Viewer to other data files. To apply the source montages 
to other data files, such as a scalp data file viewed as a source waveform file in 
the Net Station Viewer, choose a source montage from the Montage menu or the 
Montage pop-up menu of the Net Station Viewer (Figure 3-25).

Note: Once you have applied and saved a source waveform file, the montage remains 
fixed. To view or save the data with a different montage, you must be actively viewing 
the source solution of a linked scalp data file.

Figure 3-24. Viewing only the dipoles of a selected user-defined source montage
in the GeoSource Viewer (with crosshairs toggled off)

Figure 3-25. Applying source montages using the montage menus in the Net Station Viewer

Names of the dipole groups in the selected source montage

(showing Y and Z directions) (showing X and Z directions) (showing X and Y directions)
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When you select a source montage in the Net Station Viewer, the waveforms 
that are displayed represent dipole groups and not individual dipoles. See 
Figure 3-26. 

Editing, Cloning, or Deleting a Source Montage

To edit, clone, or delete a source montage, you:

• must use the Source Montages menu in the GeoSource Viewer;
• can change only one source montage at a time;
• can edit and delete only the user-defined source montages;
• must clone built-in source montages (Brodmann Areas [BAs] and Gyri) before

you can edit them; and
• must have the source montage to be changed currently open (that is, applied to

source data in the GeoSource Viewer).

Edited or cloned source montages are immediately available in the Source Montages 
menu in the GeoSource Viewer and in the Montage menu and Montage pop-up menu 
in the Net Station Viewer. Deleted source montages are immediately removed from 
these same menus.

Note: User-defined source montages are saved in files in the GeoSource folder (Documents/Net 
Station User Data/GeoSource). To share user-defined source montages between users or 
computers, copy and paste the desired files in the corresponding folder on the desired computer.

Figure 3-26. Applying a source montage to source waveforms in the Net Station Viewer
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To edit, clone, or delete a source montage, do the following:

1 View or open a source data file in the GeoSource Viewer. Remember that source 
data in the GeoSource Viewer is in the form of MRI slices.

2 Apply the source montage that you wish to change by choosing Source 
Montages > {montage name}. Note that the edit, clone, or delete commands are 
not available if no source montage is applied to source data. See Figure 3-27. 

3 Edit (step a), clone (step b), or delete (step c) the applied source montage. See 
Figure 3-28. 

Figure 3-27. Montage-editing commands are available only
when a source montage is currently applied

Figure 3-28. Dipole-group parameters in the Source Montage Editor window

Available commands if 
no montage is applied

Available commands if 
a montage is applied

Note: The commands 
apply only to the currently 
applied montage.

Parameters for the 
dipole group that is 
highlighted in the 
left pane 

Default values for 
creating a new 
dipole group

Icon indicating
the original

dipole-group
creation method
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a If you choose Edit Montage from the Source Montages menu, the Source 
Montage Editor window appears (Figure 3-28 above), and you can add 
dipoles or dipole groups (first bullet below), delete dipoles or dipole groups 
(second bullet below), or rename dipole groups (third bullet below) within 
the source montage.

Note: You cannot change the radius or threshold of dipole groups that were created 
with the Radius or Threshold dipole-group creation methods.

• You can add dipoles to only those groups that were created by the
Selected dipole-group creation method. However, you can convert a
Radius or Threshold dipole group to a Selected dipole group by first
deleting one dipole in the group; then, you can add dipoles to that group.

To add dipoles to selected dipole groups, do the following:

– In the Source Montage Editor window, click a dipole group in the
left pane to display its dipoles in the right pane.

– Shift-click dipoles in the MRI panes of the GeoSource Viewer. Shift-
clicking adds voxels to the current dipole group.

– Repeat for other dipole groups in the source montage, if desired.
– If you are done with all changes, click the Accept button to save the

changes. Otherwise, continue to the next bullet to make further
changes to this source montage.

• You can delete dipole groups or individual dipoles from any dipole
group, regardless of what dipole-group creation method was used to
create it, but heed the following caution.

CAUTION:  If you delete dipoles from dipole groups that were 
created with the Radius or Threshold dipole-group creation methods, 
they will no longer be Radius or Threshold dipole groups. They will 
functionally be Selected dipole groups. Their icon will change to show 
this changed status. Depending upon how you named these groups 
previously, make sure that you rename them to note their changed 
status; otherwise, you may make misassessments in future analyses.

To delete dipole groups, do the following:

– In the Source Montage Editor window, click a dipole group in the
left pane.

– Press the Delete key. No confirmation dialog appears.
– Repeat for other dipole groups in the source montage, if desired.
– If you are done with all changes, click the Accept button to save the

changes.
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To delete dipoles from dipole groups, do the following: 

– In the Source Montage Editor window, click a dipole group in the
left pane to display its dipoles in the right pane.

– Click or Shift-click one or more dipoles in the right pane.

Note: Before you press the Delete key in the next step, be aware that you
will not get a confirmation dialog and the deletion is not reversible, unless
you cancel all changes to the source montage by clicking Cancel.

– Press the Delete key. No confirmation dialog appears.

– If you are deleting dipoles from a dipole group that was created
with the Radius or Threshold dipole-group creation method,
rename both the dipole group and the source montage so that you
avoid making misassessments in future analyses due to using a
dipole group that has been converted into a Selected dipole group.

– Repeat for other dipole groups in the source montage, if desired.

– If you are done with all changes, click the Accept button to save the
changes. Otherwise, continue to the next bullet to make further
changes to this source montage.

• You can rename dipole groups and the source montage.

To rename dipole groups and/or the source montage, do the following:

– To rename a dipole group, double-click a dipole group in the left
pane and type your change.

– To rename a source montage, click to insert an insertion point or
double-click to select the entire name, then type your change.

– Repeat for other dipole groups in the source montage, if desired.

– If you are done with all changes, click the Accept button to save the
changes. Otherwise, go back to the previous bullets to make further 
changes to this source montage.

• When you are completely done making editing changes in the source
montage, click the Accept button to save all changes.

b If you choose Clone Montage, the Source Montage Editor window appears.

To clone a source montage, do the following: 

• Rename the clone of the original source montage to something unique.

• If needed, edit the cloned source montage as described in step a.
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c If you choose Delete Montage, a confirmation dialog appears (Figure 3-29). 
Make sure that you do, in fact, want to delete the source montage. 

Creating a Source-Imaging Specification

The Source-Imaging Specification Editor window (Figure 3-33) provides a variety of 
options to choose from. To use the window, the user must be familiar with the 
components of source-imaging specifications and how those components interact.

You will be able to perform the same tasks with your user-defined source-imaging 
specifications as you can with the default specifications.

Detailed descriptions of the components of source-imaging specifications are 
provided in Chapter 2, “GeoSource Menus and Windows,” and in Chapter 4, “Source-
Imaging Specifications.” 

To create a source-imaging specification, do the following:

1 Open a scalp data file in Net Station.

2 Open the Source-Imaging Specification Editor window. You can do it one of 
three ways:

• From the Net Station menu bar, choose GeoSource > New Source-Imaging
Specification (Figure 3-30).

Figure 3-29. Confirmation dialog for the Delete Montage command

Figure 3-30. Using the GeoSource menu to open
the Source-Imaging Specification Editor window
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• From the Net Station menu bar, choose GeoSource > GeoSource Controls,
and click the New button in the GeoSource Controls window (Figure 3-31).

• From the Net Station menu bar, choose Tools > Waveform Tools > Create >
GeoSource, and click the New button in the GeoSource Specification Editor
window (which is not to be confused with the Source-Imaging Specification
Editor window). See Figure 3-32.

Figure 3-31. Using the GeoSource Controls window to open
the Source-Imaging Specification Editor window

Figure 3-32. Using the GeoSource Specification Editor window to open
the Source-Imaging Specification Editor window
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3 In the Source-Imaging Specification Editor window that appears, specify the 
parameters of the forward head model and the inverse model, and click the 
Save button. See Figure 3-33. 

The new source-imaging specification automatically appears in the GeoSource 
Controls window and the GeoSource Specification Editor window. See Figure 3-34. 

Figure 3-33. Using the Source-Imaging Specification Editor window to specify
the parameters for a new user-defined source-imaging specification

Figure 3-34. New source-imaging specifications automatically appear
along with the default source-imaging specifications
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Editing, Cloning, or Deleting a Source-Imaging 
Specification

Your user-defined source-imaging specifications (see “Creating a Source-Imaging 
Specification” on page 88) can be edited, cloned, or deleted. The default source-
imaging specifications can only be cloned. 

To edit, clone, or delete a source-imaging specification, do the following:

1 Access the GeoSource Controls window or the GeoSource Specification Editor 
window. 

To access the GeoSource Controls window, do the following:

a Open a scalp data file in Net Station.

b From the Net Station menu bar, choose GeoSource > GeoSource 
Controls.

To access the GeoSource Specification Editor window, do one of the following:

• If you do not already have Net Station open, double-click the application
icon and, from the Net Station start-up window, choose Waveform Tools
> Create > GeoSource.

• From the Net Station menu bar, choose Tools > Waveform Tools > Create
> GeoSource.

2 Select a default or user-defined source-imaging specification from either the 
GeoSource Controls window or the GeoSource Specification Editor window.

To select a default source-imaging specification, do the following:

a In either window, click a default source-imaging specification (LAURA, 
LORETA, or sLORETA) to select it.
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b Notice that only the New and Clone buttons are active (Figure 3-35). 

To select a user-defined source-imaging specification, do the following:

a In either window, click a user-defined source-imaging specification to 
select it. 

b Notice that all four buttons (New, Edit, Clone, and Delete) are active 
(Figure 3-36). 

Figure 3-35. Default source-imaging specifications can only be cloned
(they cannot be edited or deleted)

Figure 3-36. User-defined source-imaging specifications can be
edited, cloned, or deleted
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3 To edit a user-defined source-imaging specification, do the following:

Note: Remember that you cannot edit a default source-imaging specification.

a With a specification selected (step 2), click the Edit button. This opens the 
Source-Imaging Specification Editor window (Figure 3-37).

b Edit the parameters as desired.

c Click the Save button.

The edited source-imaging specification automatically appears in the 
GeoSource Controls window and the GeoSource Specification Editor window. 

4 To clone a default or user-defined source-imaging specification, do the 
following:

a With a specification selected (step 2), click the Clone button. This opens 
the Source-Imaging Specification Editor window (Figure 3-37) with a 
copy of the selected source-imaging specification.

b Assign a unique name to the clone (i.e, copy).

c Edit the parameters, if desired.

d Click the Save button.

The cloned source-imaging specification automatically appears in the 
GeoSource Controls window and the GeoSource Specification Editor window. 

Figure 3-37. Source-Imaging Specification Editor window
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5 To delete a user-defined source-imaging specification, do the following:

a With a specification selected (step 2), click the Delete button. A 
confirmation dialog appears (Figure 3-38).

b Make sure that you do, in fact, want to delete the source-imaging 
specification, then click OK. 

Creating a GeoSource Specification

GeoSource specifications consist of a source-imaging specification and output format 
(Net Station recording or source binary). They can be added to a script or used to 
process a batch of files.

To create a GeoSource specification, do the following:

1 Open the Waveform Tools window by one of two ways:

• From the Net Station menu bar, choose Tools > Waveform Tools.

• From the Net Station start-up window, choose Waveform Tools.

2 Open the GeoSource Specification Editor window (Figure 3-39) by choosing 
Create > GeoSource.

Figure 3-38. Confirmation dialog for deleting source-imaging specifications
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3 To create a new GeoSource specification, do the following:

• Specify the name and output options.

• Select a source-imaging specification by clicking it. A green circle will appear 
next to it.

• Select a source montage by clicking it. A green circle will appear next to it.

• Choose a File Type.

• If Source Binary File is selected as the file type, choose whether to save the
data as one or three waveforms.

• Click the red Close button in the upper-left corner of the window.

Figure 3-39. GeoSource Specification Editor window for creating new GeoSource specifications
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User Tips

Following are some basic tips for using GeoSource:

• Organize your desktop. Many windows can be open while using GeoSource, so
it is a good idea to standardize the way your desktop is arranged. For example,
place the scalp waveforms being viewed in the Net Station Viewer in the same
spot on your monitor screen every time.

• Refer to other EEG analysis tools. Use the GeoSource solutions in conjunction
with other EEG tools, such as Net Station’s chart, topo plot, and topo map
views, or the results from other imaging modalities.
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CHAPTER 4SOURCE-IMAGING 
SPECIFICATIONS

source-imaging specification contains the parameters for a forward algorithm for 
EEG, head conductivity and geometry settings, an inverse method, and 

applicable weighting, constraint, and regularization techniques. It estimates the 
source locations that are responsible for the EEG data measured on the scalp. All of 
these components are described in this chapter. 

Source-Imaging Specification Components

The source-imaging specification involves two main components:

• a head model
• an inverse method 

Forward Algorithms for EEG
For a given set of source (i.e., dipole) locations, the geometry of the conductive media 
(i.e., shape of the brain, cerebrospinal fluid (CSF), skull, and scalp), the conductivity of 
each media, and the location of EEG sensors on the scalp, we can calculate the voltage 
potential recorded by the EEG sensors for each source. This calculation is known as 
the lead-field calculation and may be performed using different assumptions (such as 
spheres for geometry).

The resulting calculation is known as the forward matrix, which contains dipoles by 
EEG sensors (see Figure 4-2 on page 99). Note that because the number of sensors 
does not equal the number of dipoles, the forward matrix is nonsquare.

GeoSource’s forward models for EEG are the Sun-Stok 4-shell sphere, a spherical head 
model (page 36, page 98, and page 122), and the finite difference model (FDM), a 
realistic head model (page 37, page 98, and page 114). 

A
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Sun-Stok

As an isotropic model, the Sun-Stok consists of four 
shells that represent the brain, cerebrospinal fluid 
(CSF), skull, and scalp. The radii and their 
conductivity values are shown in Figure 4-1. 

The geometry and conductivity values for the Sun-Stok model are listed in Table 4-1.  

Finite Difference Model (FDM)

A finite difference model (FDM) is a realistic 3D 
representation of the head. In GeoSource, the FDM is 
based on a realistic MRI (page 31 and page 39) and 
uses an isotropic model of tissue conductivities. 

The conductivity values for the FDM model are listed in Table 4-2. 

Figure 4-1. Sun-Stok shells

Table 4-1. Sun-Stok values

Shell Radii (cm)
Radial conductivity

(siemens per meter [S/m])
Tangential conductivity

(siemens per meter [S/m])

Scalp (σ4) 7.5 0.33 0.33

Skull (σ3) 7.1 0.0042 0.0042

CSF (σ2) 6.5 1 1

Brain (σ1) 6.3 0.33 0.33

Remember that isotropic 
models have identical 
conductivity in all directions.

Brain σ1

CSF σ2

Scalp σ4

Skull σ3

Remember that isotropic 
models have identical 
conductivity in all directions.
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EEG Sources
GeoSource offers a dense set of dipole locations. Sources in the FDM consist of 2,447 
dipoles distributed throughout the gray matter. Each dipole is represented by a triple 
regional source, which consists of three dipoles in the X, Y, and Z orthogonal orientations.

This dipole set produces a nonsquare forward matrix (see page 97). When a nonsquare 
forward matrix is inverted using a pseudoinverse, the solution is either 
underdetermined or overdetermined. 

Underdetermined and Overdetermined Solutions

An underdetermined solution exists when there are more dipole sources than EEG 
sensors (in mathematical terminology, more unknowns than equations). See Figure 4-2. 
MNLS is used by GeoSource when the solution is underdetermined. 

An overdetermined solution exists when there are more EEG sensors than dipole 
sources (more equations than unknowns).

Table 4-2. FDM conductivity values (Ferre, et al., 2000)

Shell Radii (cm)
Conductivity 

(siemens per meter [S/m])

Scalp (σ4) 9.2 0.44

Skull (σ3) 8.7 0.018

CSF (σ2) 8.2 1.79

Brain (σ1) 8.0 0.25

Figure 4-2. Underdetermined (left) and overdetermined (right) solutions
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Minimum Norm Least Squares (MNLS)
Least squares is a mathematical process that finds the best-fitting curve to a set of points 
by minimizing the sum of the squares of the offsets of the points from the curve. The 
result is an infinite number of possible least-squares solutions. Minimum norm captures 
a unique solution by choosing the one that uses the least amount of energy.

Weighting

The MNLS technique, used by GeoSource when the solution is underdetermined, 
produces a unique solution because only one combination of sources can simultaneously 
explain the data and be of lowest overall intensity. Weaker and more localized solutions 
are favored because less activity is required to explain the measured data, and, 
consequently, deeper sources are often “incorrectly” projected on the surface, which 
means that the MNLS technique has a superficial bias.

Constraint Schemes
Constraints can be applied to the inverse process to overcome the superficial bias of 
the MNLS technique. GeoSource offers three constraint schemes: 

• LAURA
• LORETA
• sLORETA

LAURA

LAURA (local autoregressive average) is a constraint that is based on biophysical laws. 
According to electromagnetic theory, the strength of the source falls off with the 
inverse of the cubic distance for vector fields and with the inverse of the squared 
distance for potential fields. 

LAURA constrains a solution based on two factors: (1) the theory that the strength of a 
dipole decreases as the distance from the source increases, and (2) the local 
autoregressive average of coefficients that depend on the distance between solution 
points. The weighting is based on the mean of norms of all three sources (X, Y, and Z) 
at each dipole location. The constraint is based on the closest neighbors for each 
location, and the falloff is proportional to the inverse of the distance cubed.
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For further information, please reference:

• Grave de Peralta Menendez, R., Gonzalez Andino, S.L., Lantz, G., Michel, C.M.,
& Landis, T. (2001). Noninvasive localization of electromagnetic epileptic
activity. I. Method descriptions and simulations. Brain Topogr, 14, 131–137.

• Grave de Peralta, R., & Gonzalez, Andino, S. (2002). Comparison of algorithms for 
the localization of focal sources: Evaluation with simulated data and analysis of
experimental data. International Journal of Bioelectromagnetism, online journal.

• Grave de Peralta, R., Murray, M.M., Michel, C.M., Martuzzi, R., & Gonzalez,
Andino S. (2004a). Electrical neuroimaging based on biophysical constraints.
Neuroimage, 21:527–39.

LORETA

LORETA (low-resolution brain electromagnetic tomography) assumes that physiological 
properties act as constraints to the depth weighting in the minimum norm algorithm. 
Specifically, this scheme assumes that the activity in neurons in neighboring patches 
of cortex is related and selects the solution with the smoothest spatial distribution by 
minimizing the Laplacian of the weighted sources, which is a measure of spatial 
roughness. This results in a rather “blurred” solution. The weighting is based on the 
norm of all three sources (X, Y, and Z) at each dipole location.

For further information, please reference:

• Pascual-Marqui, R.D. (1999). Review of methods for solving the EEG inverse
problem. International Journal of Bioelectromagnetism, 1: 75-86.

• Pascual-Marqui, R.D., Michel, C.M., & Lehmann, D. (1994). Low resolution
electromagnetic tomography: a new method for localizing electrical activity in
the brain. International Journal of Psychophysiology, 18: 49-65.

sLORETA

sLORETA (standardized low-resolution brain electromagnetic tomography) also assumes 
that physiological properties act as constraints to the depth weighting in the 
minimum norm algorithm. The difference between sLORETA and LORETA, however, 
is that sLORETA selects the solution that standardizes the source current density such 
that there is equal sensitivity for deep and superficial sources. 

For further information, please reference:

• Pascual-Marqui, R.D. (2002). Standardized low resolution brain electromagnetic
tomography (sLORETA): technical details. Methods & Findings in Experimental
& Clinical Pharmacology, 24D:5-12.
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Regularization
To account for noise in the data, regularization must be employed. Apart from explaining 
some of the variance in the data caused by noise, regularization also provides stability 
to the source solution, preventing small variations (assumed to be noise) in the data 
from leading to large variations in the distribution of activity in the solution.

GeoSource offers the Tikhonov regularization method.

Suggested Reading

Following is a list of references for this chapter:

• Ferre, T.C., Eriksen, K.J., and Tucker, D.M. (2000). Regional head tissue
conductivity estimation for improved EEG analysis. IEEE Transactions on
Biomedical Engineering, 47(12), 1584–1592.

• Gorodnitsky, I.F., George, J.S., & Rao, B.D. (1995). Neuromagnetic source
imaging with FOCUSS: A recursive weighted minimum norm algorithm.
Electroencephalography and Clinical Neurophysiology, 95, 231–251.

• Grave de Peralta, R., & Gonzalez Andino, S. (2002). Comparison of algorithms
for the localization of focal sources: Evaluation with simulated data and
analysis of experimental data. International Journal of Bioelectromagnetism,
online journal.

• Lemieux, L., McBride, A., & Hand, J.W. (1996). Calculation of electrical
potentials on the surface of a realistic head model by finite differences. Physics
in Medicine and Biology, 41, 1079–1091.

• Michel, C.M, Murray, M.M., Lantz, G., Gonzalez, S., Spinelli, L., & Grave de
Peralta, R. (2004). EEG source imaging. Clinical Neurophysiology, 115(10), 2195–
2222.

• Neumaier, A. (1998). Solving ill-conditioned and singular linear systems: A
tutorial on regularization. SIAM Review, 40, 636–666.

• Pascual-Marqui, R.D. (1991). Review of methods for solving the EEG inverse
problem. International Journal of Bioelectromagnetism, 1, 75–86.

• Sun, M. (1997). An efficient algorithm for computing multishell spherical
volume conductor models in EEG dipole source localization. IEEE Transactions 
on Biomedical Engineering, 44(12), 1243–1252.
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CHAPTER 5GEOSOURCE FILE 
ORGANIZATION

eoSource is an extension of Net Station. Consequently, some of the GeoSource 
application files reside inside of Net Station’s folders, while others reside outside 

of them. 

This chapter describes the GeoSource files and their file locations. These include 
output, application, and related files. For more information about Net Station file 
organization, see the Net Station Acquisition Technical Manual.

Output Files

GeoSource outputs the following file formats: 

• a Net Station MFF recording file
• a source binary file
• a tab-delimited text file
• a MATLAB .MAT file
• a modified Net Station recording file

Note: If you are seeing a longer list of available formats than are shown in the list above, 
you have not yet converted the original Net Station EEG recording file into a GeoSource 
view (or file). Stop, and review the “What to Know Before Getting Started” section in 
Chapter 3. You must create a GeoSource view using a source-imaging specification before 
you can convert an original Net Station EEG recording file into a GeoSource file.

You can save these files to any folder you choose. 

G
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Net Station MFF Recording
A file output from Net Station for GeoSource using the Net Station 
MFF Recording format option contains the source data in EGI’s 
format for all data (EEG, wavelets, source data, T-Test, etc.). This file 
format contains the information for all selected dipoles, is not 
constrained by any size limit, and is fully integrated with Net Station. 
This format stores sample data in binary blocks and stores information 
about those samples in XML text files. For more information, request 
MFF documentation from EGI Support at supportteam@egi.com.

Source Binary 
A file output from Net Station for GeoSource using the Source Binary 
File format option contains the source waveform data in a simple 
form that allows users to write applications for analyzing the data. 
This file format is similar in format to a normal simple binary file, 
which consists of a file header followed by data and events, but, 
whereas a normal simple binary file intersperses events throughout a 
file, this modified simple binary file stores events at the end of a file.

Capable of holding any kind of data, this simple binary file format is not limited to 
2 GB in size, and consequently can easily accommodate large numbers of dipoles.

You can save a file in a sparse simple binary file format from the Net Station menus, 
depending on your current operation, by choosing File > Save or by choosing Tools > 
Waveform Tools > Create > GeoSource and, at the File Type pop-up menu, choosing 
Binary File. 

When you save a dense simple binary source file by choosing File > Save from the Net 
Station menus, the resulting file contains only the active source montage of the dense 
solution set. When you save a dense simple binary source file by choosing Tools > 
Waveform Tools > Create > GeoSource > File Type > Binary File, the resulting file 
contains the entire dense solution set or the solution set for the selected montage.

Net Station MFF 
Recording file icon

Source binary 
file icon
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Tab-delimited Text
A file output from Net Station for GeoSource using the Tab-delimited 
Text format option contains the source data in a simple form that 
allows users to read the data into Excel or to write applications for 
analyzing the data. As a single, unsegmented block of source data 
that is saved with one level of precision and one type of unit 
(nanoamp meters), this format contains no metadata, events, or 

header. Because using this format is time-consuming and generates large files, we 
recommend exporting small files or selections of files to this format.

The tab-delimited text format is similar to the simple binary file format in terms of its 
file-size limits and export options. 

MATLAB .MAT
A file output from Net Station for GeoSource using the MATLAB 
.MAT format option contains the source data in a format suitable for 
MATLAB programming. 

Net Station provides three output options for data being exported to 
the MATLAB .MAT format: nanoamp meters, no events, and double-
point precision. 

You can export to three arrays:

• individual arrays
• cell array
• 3D array

The MATLAB .MAT format is similar to the simple binary format in terms of its file-
size limits and export options.

Text file icon

MATLAB icon
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Net Station Recording 
A file output from Net Station for GeoSource using the Net Station 
Recording format option contains source data in a format similar to 
that of a Net Station EEG recording file, which is an object-oriented 
database consisting of elements, tracks, and epochs. Many waveform 
tool operations can be performed on these files (see page 17 for a list 
of tools). Note that you can open these files in the Net Station Viewer 
but you cannot transform the data back to scalp data.

You can save a file in the Net Station recording format from the Net Station menus, 
depending on your current operation, by choosing File > Save or by choosing Tools > 
Waveform Tools > Create > GeoSource and, at the File Type pop-up menu, choosing 
Net Station Recording. This file format can contain a source montage dense data set, 
because the entire dense solution set would exceed Net Station’s 2-GB file-size limit. 
Each dipole location is represented by three waveforms—one for each orthogonal 
orientation (X, Y, and Z). The units are in nanoamp meters.

The file history information contains enough detail to reconstruct the file, if needed. 
To view this information—which includes the source-imaging specification 
parameters—open the file, choose Edit > File Info, and click the History tab. 

File Formats Manual
For more information about these file formats, refer the Net Station File Formats 
Technical Manual.

GeoSource Application Files

The GeoSource application files consist of EEG sources and source montages. The 
application files reside in the GeoSource folder in the Net Station User Data folder and 
in the Net Station Application Program Package.

CAUTION: The Net Station Application Program Package is not intended for 
customer use. It should not be opened and none of its items moved, renamed, or 
deleted, or else Net Station may exhibit unexpected behavior, including data 
corruption.

Net Station 
Recording file icon
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GeoSource-Related Files

GeoSource-related files are stand-alone files that are used in the software. GeoSource 
uses two kinds of files to approximate source data in the brain (forward algorithms for 
EEG and average MRI files). Both are stored in the Net Station Application Program 
Package. 

CAUTION: The Net Station Application Program Package is not intended for 
customer use. It should not be opened and none of its items moved, renamed, or 
deleted, or else Net Station may exhibit unexpected behavior, including data 
corruption.

GeoSource File Summary

Table 5-1 summarizes this chapter.

Table 5-1. GeoSource files and locations

Settings Description Storage location

Net Station MFF 
Recording file format

Derived source waveform data saved in a 
file format similar to that of a Net Station 
EEG recording file that differs by storing 
sample data in binary blocks and storing 
information about those samples in XML 
text files, which is designed for data 
accessibility from any language using any 
operating system and which allows 
extended continuous recordings to be 
compressed into a single file (without any 
additional steps needed to stitch separate 
files together). 

<user-selected folder>

Source Binary File format Derived source waveform data saved in a 
file format similar to that of a normal 
simple binary file, which contains a header 
followed by data and events; however, in 
a GeoSource simple binary file, the events 
are stored at the end of the file.

<user-selected folder>

Tab-delimited Text 
format

Derived source waveform data saved in a 
file format that contains no metadata, 
events, or header.

<user-selected folder>



Chapter 5: GeoSource File Organization

108 GeoSource 2.0 Technical Manual  8103101-52 • March 9, 2015

MATLAB .MAT format Derived source waveform data saved in a 
file format that is designed for 
compatibility with MATLAB programs.

<user-selected folder>

Net Station Recording file 
format

Derived source waveform data saved in a 
file format similar to that of a Net Station 
EEG recording file, which is an object-
oriented database.

<user-selected folder>

EEG sources Set of assumed dipole locations that is 
used for determining the initial dipole 
locations in the cortex for the forward 
model.

User-defined sets:
 /Users/<username>/ 
 Documents/Net Station User
 Data/GeoSource

Built-in sets:
 /Applications/Net Station/
 Net Station.app/GeoSource/
 Do not open this package.

Source montage User-created subset of a dense solution set 
that allows you to display only the dipoles 
of interest.

User-defined montages:
 /Users/<username>/ 
 Documents/Net Station User
 Data/GeoSource

Built-in montages:
 /Applications/Net Station/
 Net Station.app/GeoSource/
 Do not open this package.

Forward algorithm for 
EEG

Mathematical technique used to calculate 
the voltage at the sensors, when a dipole 
has a unit activation, for a given head 
volume geometry and conductivity, dipole 
locations, and sensor locations.

/Applications/Net Station/
Net Station.app/GeoSource/
Do not open this package.

Average MRI Used for 3D display of the derived source 
locations.

/Applications/Net Station/
Net Station.app/GeoSource/
Do not open this package.

Table 5-1. GeoSource files and locations

Settings Description Storage location
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Appendix A

APPENDIX ASOFTWARE 
TECHNICAL SUPPORT

Before Contacting EGI

Please check this manual’s contents on 
page v or index on page 125 for coverage 
of your issue or question. You can also 
perform an electronic search using Find 
or Search in the PDF version of this 
manual, which is posted on the 
documentation page of the EGI website 
(www.egi.com/membership-area).

In addition, the Support page of the EGI 
website (www.egi.com/support) may 
have the information you need.

If you need more help, EGI recommends 
the following:

• Isolate the problem. Try to repeat
and define the problem.

• Document the problem. Carefully
record the sequential details of the
isolated problem.

• Report the defined problem.
Contact EGI by web, email, phone,
fax, or postal mail.

Contacting EGI

EGI Support

web page

www.egi.com/support

Email support supportteam@egi.com

Sales 

information

info@egi.com

Telephone +541-687-7962

Fax +541-687-7963

Address Electrical Geodesics, Inc.      

500 E 4th Avenue, Suite 200 

Eugene, OR 97401

USA

http://www.egi.com/documentation.html
http://www.egi.com/documentation.html
http://www.egi.com/documentation.html
http:///www.egi.com/support.html
http:///www.egi.com/support.html
http://www.egi.com/support.html
http://www.egi.com/support.html
http://www.egi.com/support.html
mailto:support@egi.com
mailto:info@egi.com
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GLOSSARY

Note: If a word is italicized in a definition, then that word (or a variant) is also defined in 
this glossary.

A

algorithm   A set of instructions used to solve a problem or obtain a desired result. For 
example, the “shampoo algorithm” explains how to wash one's hair: wet hair, lather, 
rinse, repeat. Gaussian elimination is an algorithm for solving linear systems of 
equations.

axon   The usually long process of a nerve fiber that generally conducts impulses away 
from the body of the neuron.

C

cell body   The portion of a neuron that contains the nucleus but does not incorporate 
the dendrites or axon. Also called “soma.”

cerebral cortex   The extensive outer layer of gray matter of the cerebral hemispheres, 
largely responsible for higher brain functions, including sensation, voluntary muscle 
movement, thought, reasoning, and memory.

cerebrospinal fluid (CSF)   The serumlike fluid that circulates through the ventricles of 
the brain, the cavity of the spinal cord, and the subarachnoid space, functioning in 
shock absorption.

channel   Each sensor of the Geodesic Sensor Net is cabled into the amplifier where its 
signal is converted into a stream of digital values. Each of these streams is the data of a 
channel.
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coefficient   The number multiplied times a product of variables or powers of variables 
in a term. For example, 123 is the coefficient in the term 123x3y.

coefficient matrix   The matrix formed by the coefficients in a linear system of 
equations.

column (of a matrix)   A vertical set of numbers in a matrix.

condition number   The ratio of the largest to smallest singular value in the singular 
value decomposition of a matrix.

conductivity   A measure of the tendency of a material to transmit electrons; opposite 
of impedance or resistance.

constraint scheme   A scheme that imposes constraints on the source space by using 
prior anatomical or physiological information, often derived from other imaging 
modalities. In effect, this type of scheme places bounds on the norm. The inverse 
method is then applied to the reduced source space to yield a solution set. GeoSource 
offers three constraint schemes: LAURA, LORETA, and sLORETA.

current   Measured in amperes, this is the flow of electrons through a conductor. Also 
know as “electron flow.”

D

dendrite   A branched protoplasmic extension of a neuron that conducts impulses from 
adjacent cells inward toward the cell body. A single nerve may possess many 
dendrites. Also called “dendron.”

dense (sensor) array   Any (sensor) system that supports a sufficient number of 
sensors to spatially sample a phenomenon adequately. For EEG recording, this 
generally means 64 or more channels. For source estimation, this means 128 or 256 
channels.

determinant   The value computed from a square matrix of numbers by a rule of 
combining products of the matrix elements and that characterizes the solvability of 
simultaneous linear equations. Its absolute value can be interpreted as an area or 
volume. 

diagonal matrix   A square matrix whose array contains constants on the diagonal and 
0’s everywhere else. 
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dipolar   Of or relating to dipole.

dipole   A pair of electric charges, of equal magnitude but opposite polarity, separated 
by a small distance. Each dipole has a location and orientation.

dipole activation   The degree of power of the electrical current sent from the dendrite 
to the cell body. 

dipole location   The cortical section where the dipole is situated. The cortical section 
may be synonymous with the dipole.

dipole orientation   The direction in which the dipole is pointing.

E

EEG   See electroencephalography.

EEG sources   This dipole set bases the dipole locations on a realistic head shape 
(specifically, the average magnetic resonance image from the Montreal Neurological 
Institute), but uses a spherical shape to solve the inverse EEG problem. The dense set 
evenly spaces thousands of dipoles over the head shape.

electrical field   A field or force that exists in the space between two different 
potentials or voltages. Also known as “electrostatic field.”

electroencephalography   Science of recording and analyzing the electrical activity of 
the brain. 

element (of a matrix)   One of the entries in a matrix. The address of an element is 
given by listing the row number, then the column number.

elementary row operation   The following methods used to transform matrices: 
trading two rows, multiplying a row by a nonzero scalar, or adding a scalar multiple of 
one row to another row.

F

FDM   See finite difference model.



Glossary

114 GeoSource 2.0 Technical Manual 8103101-52 • March 9, 2015

Finder   On Macintosh computers, the Finder is the program that keeps track of files 
and folders, and displays the desktop (the working area on the screen with disk icons, 
a Trash icon, and so on).

finite difference model (FDM)   A 3D realistic head model based on finite differences, in 
which the basic calculation elements are nodes on a rectangular grid. The realistically 
shaped head model is obtained from 3D magnetic resonance images, and each cubic 
grid is allocated a specific conductivity, depending on the compartment in which it is 
located. In GeoSource, the conductivity values are fixed.

fixed   Constant; not changing or moving.

forward algorithm for EEG   For a given head volume geometry and conductivity, dipole 
locations, and sensor locations, this is the mathematical technique used to calculate the 
voltage at the sensors when the dipole has a unit activation. In the Source-Imaging 
Specification Editor window, GeoSource offers these choices: finite difference model 
(FDM) and Sun-Stok 4-shell sphere. 

forward EEG matrix   The linear transformations used to relate known dipole locations 
and activations to measured EEG locations and activations on the scalp. The matrix 
contains one column per dipole, one row per sensor, and one column topography for 
each unit dipole. The elements in this matrix result from the forward algorithm for EEG. 

forward EEG model   In GeoSource, this model is created by choosing a forward 
algorithm for EEG and a head geometry and conductivity setting and combining them 
with the EEG data (sensor locations). This is used to solve the forward EEG problem.

forward EEG problem   Given known dipole locations and activations and head volume 
geometry and conductivity and sensor locations (from the EEG data), the goal is to 
estimate the EEG as it appears on the scalp. In GeoSource, this is solved using a 
forward EEG model. 

forward problem   Given known source data and propagation model, the goal is to 
estimate the surface measurements. 

G

geodesic   The shortest distance between two points on the surface of a sphere. The 
Geodesic Sensor Net is a structure of elastomer lines in the approximation of a 
geodesic.
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Geodesic Sensor Net (GSN)   Electrical Geodesics Inc.’s dense sensor array.

geometry   Surface shape.

gray matter   See cerebral cortex.

GSN   See Geodesic Sensor Net.

gyrus   Any of the prominent, rounded, elevated convolutions on the surfaces of the 
cerebral hemispheres.

H

head geometry and conductivity setting   A scientifically and mathematically based 
method that represents a reconstruction of the shape and conductivity properties of a 
human head. 

I

identity matrix   The simplest nontrivial diagonal matrix, defined such that IX = X for 
all vectors X. The identity matrix thus functions like the number “1,” and its array 
consists of 1’s on the diagonal and 0’s everywhere else.

ill-posed problem   First defined in 1902 by the mathematician Jacques Hadamard, an 
ill-posed problem fails to meet one or more of the following:

• For each set of data, there exists a solution.
• The solution is unique.
• The solution depends continuously on the data.

In other words, an ill-posed problem is one whose solution does not exist, is not 
unique, or is not stable under perturbations on the data. A matrix is ill posed if its 
condition number is large. Most inverse solutions are ill posed because they tend to be 
highly underdetermined. Overdetermined solutions can be ill posed as well, but they 
tend to be more stable overall.

impedance   The alternating-current equivalent of resistance, impedance is the 
measurement of the resistance to the flow of electricity for a particular substance. 
Electrode/scalp impedances affect waveform susceptibility to environmental noise. 
The opposite of conductivity.



Glossary

116 GeoSource 2.0 Technical Manual 8103101-52 • March 9, 2015

inverse   Reversed in order, nature, or effect. For example, the inverse of 5 is 1/5. 

inverse EEG matrix   The linear transformations that relate the measured EEG 
locations and activations to the estimated dipole locations and activations. The elements 
in this matrix result from inverting the forward EEG matrix. 

inverse EEG model   Consists of an inverse method and weighting, constraint, and/or 
regularization techniques; this model is used to invert the forward EEG model. The 
inverse EEG model is defined in the Source-Imaging Specification Editor window, 
which can be accessed by choosing GeoSource menu > New Source-Imaging 
Specification.

inverse EEG problem   Given known EEG locations/activations and head geometry/
conductivity, the goal is to estimate the dipole locations/activations. In GeoSource, this 
is solved by using a source-imaging specification and applying the result to the EEG 
scalp data. 

inverse matrix   The inverse of a nonsingular and square matrix A is a matrix A–1 such 
that AA–1 = I, where I is the identity matrix. A square matrix A has an inverse if and 
only if the determinant |A| ¦ 0. 

inverse method   Based on various assumptions about dipole locations and activations, this 
is a mathematical equation that produces a unique answer from the infinite number of 
possible answers to the inverse EEG problem. GeoSource uses the minimum-norm least 
squares (MNLS) technique when the solution is underdetermined.

inverse problem   Given known surface measurements and propagation model, the 
goal is to derive the source data. This requires solving the forward problem first. 

isotropic   Identical conductivity in all directions; invariant with respect to direction.

L

LAURA   Stands for “local autoregressive average.” LAURA uses biophysical laws to 
constrain the minimum norm. This scheme derives a solution based on two factors: (1) 
the theory that the strength of a dipole decreases as the distance from the source 
increases, and (2) the local autoregressive average of coefficients that depend on the 
distance between solution points.
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least-squares fit   The linear fit that matches the pattern of a set of paired data as 
closely as possible. Out of all possible linear fits, the least-squares regression line is the 
one that has the smallest possible value for the sum of the squares of the residuals.

linear   Like a line. A description of any graph or data that can be modeled by a linear 
polynomial. Opposite of nonlinear.

linear equation   An equation that can be written in the form ax + b = 0, where a and b 
are constants.

linear transformation   A change of variables where each variable is replaced by a 
function of the first degree in the new variable.

LORETA   Stands for “low-resolution brain electromagnetic tomography,” which is a 
Laplacian weighted minimum-norm method. LORETA relies on physiological 
theories to add constraints to the depth weighting. This scheme selects the solution 
with the smoothest spatial distribution.

M

magnetic resonance image (MRI)   Magnetic resonance imaging uses computer 
imaging of atomic response to radio waves in a magnetic field to generate imagery of 
tissue.

magnitude   In the case of EEG, the strength (i.e., the amount of current flow) of a 
source dipole as represented by the length of a vector. More generally, a property of 
relative size that is given as a scalar value having physical units.

matrix   A rectangular array of items, with m number of rows and n number of 
columns, which is denoted as m x n. Each item is called an element or “entry.”

matrix rank   The number of linearly independent rows or columns.

minimum-norm least squares (MNLS)   In a linear system of ax = b, this is the solution 
that yields the shortest vector x that achieves min x ||ax – b||. This solution assumes 
that the 3D current distribution has minimum overall intensity. GeoSource uses 
MNLS.

MNLS   See minimum-norm least squares (MNLS).
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model (mathematical)   An equation or a system of equations representing real-world 
phenomena. Models also represent patterns found in graphs and/or data. Usually 
models are not exact matches of the objects or behavior they represent. A good model 
should capture the essential character of whatever is being modeled.

montage   One of several methods of combining, selecting, or arranging data from 
multiple sensor locations, or the result of defining one of such methods. On a given 
montage, a combined waveform is a derivative of the waveforms at the sensors chosen 
to be combined. A selection of sensors results in the display of a subset of all the 
sensors originally used to make a recording.

MRI   See magnetic resonance image.

N

neuron   Any of the impulse-conducting cells that constitute the brain, spinal column, 
and nerves, consisting of a nucleated cell body with one or more dendrites and a single 
axon. Also called “nerve cell.”

noise   Any perturbation on the data that is not described by the applied models. In 
inverse solutions, a small amount of noise can create large errors, making the solution 
unstable and unreliable. GeoSource offers one method of mitigating noise: Tikhonov. 
In effect, this regularization method is based on assumptions about the smoothness of 
the norm.

nonlinear   Not depictable graphically as a straight line; not changing by a constant 
amount for each unit of time, distance, or other independent variable. Opposite of 
linear.

nonsingular matrix   A matrix that contains no column or row that is a variant of 
another column or row. If a nonsingular matrix is square, then it has an inverse matrix.

nonsquare matrix   A matrix in which the number of rows does not equal the number 
of columns.

nontrivial   A solution or example that is not trivial. Often, solutions or examples 
involving the number zero are considered trivial. Nonzero solutions or examples are 
considered nontrivial. For example, the equation x + 5y = 0 has the trivial solution 
(0, 0). Nontrivial solutions include (5, –1) and (–2, 0.4)
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O

oblique   Tilted at an angle; neither vertical nor horizontal.

orthogonal   Relating to or composed of right angles.

orthogonal matrix   Of or relating to a matrix whose transpose equals its inverse. 

overdetermined   The approach to solving the inverse EEG problem that contains fewer 
unknowns (the dipole locations/activations assumed in the dipole set) than knowns (the 
EEG locations/activations measured on the scalp). 

Overlaid Segments view   A viewing mode in the Net Station Viewer that allows you 
to view source waveforms as three overlaid waveforms per dipole location.

P

polarity   Intrinsic polar separation or orientation, especially of a physical property.

pseudoinverse   An object similar to an inverse matrix that enables rectangular matrices 
to be inverted. A well-known example is the Moore-Penrose pseudoinverse, which 
multiplies the rectangular matrix by its transpose to make a square matrix, inverts the 
square matrix, and multiplies the inverted result by the transpose to return the matrix 
to its rectangular state.

R

radial   Radiating from or converging to a common center.

realistic   Relating to the representation of an object as it is in reality. In GeoSource, a 
realistic head model is based on an average magnetic resonance image (MRI), rather 
than a spherical model. The computational capabilities required are greater, but so is 
the accuracy.

rectangular matrix   A matrix that has a different number of rows than columns 
(denoted as an m x n matrix).
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reference   An electrical point that is treated as zero for purposes of amplifying 
electrical signals. The Geodesic Sensor Net has a reference electrode located at the 
vertex.

regularization   Additional information about the solution that is introduced to an ill-
posed problem, to stabilize the solution. GeoSource offers one type of regularization: 
Tikhonov.

resistance   The opposition of a body or substance to current passing through it, 
resulting in a change of electrical energy into heat or another form of energy. Opposite 
of conductivity.

RMS view   Stands for root-mean-square view. This is a viewing mode in the Net 
Station Viewer that allows you to view source waveforms as one collapsed waveform 
(with the RMS values of all three waveforms added together) per dipole location.

root mean square (RMS)   A kind of average sometimes used in statistics and 
engineering, often abbreviated as RMS. To find the root mean square of a set of 
numbers, square all the numbers in the set and then find the arithmetic mean of the 
squares. Take the square root of the result.

row (of a matrix)   A horizontal set of numbers in a matrix.

S

sample   When a continuous signal is measured by examining it at discrete moments 
in time, each measurement corresponds to a sample.

scalar   A quantity, such as length, that is completely specified by its magnitude, and 
has no direction.

sensor   A device that picks up a signal being generated by something in the real 
world.

sensor layout   Descriptive information for a particular quantity and arrangement of 
sensors. Includes 2D and/or 3D coordinates specifying the locations of sensors, labels 
(names) of sensors, and connectivity. Such information is stored in a sensor layout file.

shell   Any of the set of hypothetical spherical surfaces centered on an inner sphere 
(representing the brain in GeoSource).
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signal   A detectable, measurable quantity that can be expected to display periodicity 
or other forms of variation in time.

singular matrix   A matrix that contains a column or row that is a variant of another 
column or row. A singular matrix has no true inverse matrix, but may be inverted 
using a pseudoinverse.

singular value   The diagonal elements of a diagonal matrix in the singular value 
decomposition equation of A = U Σ VT, where U and V are orthogonal matrices, and Σ is 
a diagonal matrix.

singular value decomposition (SVD)   A powerful and widely used group of 
techniques dealing with sets of equations or matrices that are either singular or 
numerically very close to singular. SVD allows one to diagnose the problems in a 
given matrix and provides numerical answer as well. SVD decomposes a matrix into 
several component matrices, exposing many of the useful and interesting properties of 
the original matrix. Using the SVD, we can determine the rank of matrix, quantify the 
sensitivity of a linear system to numerical error, or obtain an optimal lower-rank 
approximation to the matrix. Every m x n matrix has an SVD, which can be expressed 
as A = U Σ VT, where U and V are orthogonal matrices, and Σ is a diagonal matrix.

sLORETA   (standardized low-resolution brain electromagnetic tomography)  Like 
LORETA, sLORETA also assumes that physiological properties act as constraints to 
the depth weighting in the minimum norm algorithm. The difference between 
sLORETA and LORETA, however, is that sLORETA selects the solution that 
standardizes the source current density such that there is equal sensitivity for deep 
and superficial sources.

solution set   Any and all value(s) of the variable(s) that satisfies an equation, 
inequality, system of equations, or system of inequalities. 

source-imaging specification   In GeoSource, this is the group of settings to use when 
estimating source waveforms and dipole activations. A source-imaging specification 
consists of a forward algorithm for EEG (for the forward EEG model) and an inverse 
EEG model. Be aware that the term source-imaging specification is similar, but not 
identical, to terms such as source-localization method, inverse solution, and source-
analysis technique.

Source-Imaging Specification Editor window   This is the Net Station window where 
the source-imaging specification is defined. Accessible in a number of ways, primarily 
by choosing GeoSource menu > New Source-Imaging Specification.
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source montage   A subset of a dense dipole solution set that allows you to view only the 
dipoles of interest. In GeoSource, this is created in the GeoSource Viewer, and the 
montages can be applied in either the GeoSource Viewer or the Net Station Viewer.

source space   The set of all possible outcomes of an experiment.

sphere   A 3D solid consisting of all points equidistant from a given point. This point is 
the center of the sphere. All cross-sections of a sphere are circles.

square matrix   A matrix that has the same number of rows as columns (that is, m = n).

Sun-Stok 4-Shell Sphere   A four-shell concentric structure, with different conductivity 
values for the brain, skull, cerebrospinal fluid, and scalp spheres. The Sun-Stok 4-shell 
sphere approximates the forward solution of the multishell model directly based on 
mathematical analysis of infinite sums of Legendre and associated Legendre 
polynomials. The weighting functions of these polynomials are fit using low-order 
polynomials, and closed-form expressions for the infinite sums are derived based on 
this polynomial representation. The resulting algorithm minimizes the amount of 
computer running time.

T

tangent   A line, curve, or surface meeting another line, curve, or surface at a common 
point and sharing a common tangent line or tangent plane at that point.

tangential   Of, relating to, or moving along or in the direction of a tangent.

Tikhonov regularization   A common and well-known regularization method that 
parameterizes a whole family of solutions by the weighting factor λ2. This method 
multiplies each singular value by a constant, with the aim of increasing the small 
singular values such that when they are inverted, their effect on the stability of the 
solution is minimal. The effect of this regularization on large singular values should 
be negligible. 

transpose matrix   Created by taking the first column of a matrix A and using it as the 
first row of the transpose matrix A, taking the second column of matrix A and using it 
as the second row of the transpose matrix A, and so on. The transpose matrix is 
denoted as AT. 

trivial   A solution or example that is ridiculously simple and of little interest. Often, 
solutions or examples involving the number 0 are considered trivial. Nonzero 
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solutions or examples are considered nontrivial. For example, the equation x + 5y = 0 
has the trivial solution x = 0, y = 0. Nontrivial solutions include x = 5, y = –1 and x = –2, 
y = 0.4.

U

underdetermined   The approach to solving the inverse EEG problem that contains 
fewer knowns (the EEG locations/activations measured on the scalp) than unknowns 
(the dipole locations/activations assumed in the dipole set).

V

variable   A quantity that may increase or decrease; a quantity that admits an infinite 
number of values in the same expression; for example, in the equation x2 – y2 = R2, x 
and y are variables.

vector   (1) A quantity, such as velocity, completely specified by a magnitude and a 
direction; (2) a one-dimensional array; or (3) an element of a vector space.

vector space   A vector space V is a set that is closed under finite vector addition and 
scalar multiplication.

vertex   The point on an EEG subject’s scalp that is closest to the top of the head. In the 
International 10-20 system, Cz is the vertex electrode. In the Adult 128 GSN, electrode 
#129 is the vertex. The point on the scalp or skull located midway between the nasion 
and inion and centered between the periauricular points. Also the name of the 
Geodesic Sensor Net sensor that corresponds to this location and contains the reference 
electrode.

volt/voltage   A measure of electrical force, or the tendency for electrons to move from 
one location to another. Voltages are measured with respect to a reference.

voxel   Stands for “volume pixel,” the smallest distinguishable box-shaped part of a 
3D image.

W

waveform   Any graphical representation of a signal.



Glossary

124 GeoSource 2.0 Technical Manual 8103101-52 • March 9, 2015

weighting   A coefficient assigned to elements of a distribution, to represent their 
relative importance. The objective of weighting is to correct for biases in the 
measurement method. The inverse methods in GeoSource are all based on variants of 
minimum-norm least squares (MNLS), which favors shallow dipole locations over 
deeper sources. The weighting options offered include: per location and per 
orientation. 

well conditioned   See well posed.

well posed   The following definition was first developed in 1902 by the 
mathematician Jacques Hadamard, who noticed that inverse formulations of 
boundary value problems (or their algebraic counterpart) were often ill behaved. He 
defined the conditions for well-posed and ill-posed problems. For a problem to be 
well posed in the Hadamard sense, it must meet the following criteria:

• For each set of data, there exists a solution.
• The solution is unique.
• The solution depends continuously on the data.
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